What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

As every programmer, I ] need my ][ square ] brackets.

But at the moment, I have to switch to US layout in order to type them on StackOverflow. Since Croatia is not a big country, it's not all that important... except Hungarian layout also has square brackets in same place: -[- AltGr+F and -]- AltGr+G.

Apparently the underlying software thinks I'm holding Ctrl when I'm in fact holding AltGr... which is not the same :-)

PS StackOverflow is not the only one, this is a rare, but sufficiently common problem: Code::Blocks is mapping AltGr+F as one of its shortcuts

share|improve this question
    
You can post this on meta.stackoverflow.com - it'll get a better response there (discussion about the sites in general) :) –  ajm Jul 9 '09 at 16:16
1  
...and look at me, thinking I was on a different site :P Apologies! –  ajm Jul 9 '09 at 16:17
    
Yes, it is a common problem with SO, and on many US origin sites. It is a trivial fix as the devs need only to disable shortcut assignments on the editor. But it won't happen. You'll get further if you write a plugin for your browser which hot-fixes the SO editor. –  kd304 Jul 12 '09 at 7:51
    
possible duplicate of Why is Alt Gr + Q giving me Quote formatting instead of the @ sign? –  Kip May 14 '10 at 13:22

2 Answers 2

Same with Hungarian layout. You could use your browser's developer tools to find the hotkey assignment code and manually unassign the handler, but you have to repeat it on every page.

I suggest adding buttons for the [{ characters or create a browser plugin for that. I heard FF does not suffer this issue, but for those who use IE or Chrome on Windows is annoying.

My approach is to open Notepad and type in these characters. Then I copy-paste. (However, when I post a longer code, I already use some other external text editor to replace my tab characters to four spaces.)

(PS: i18n, I wish I had participated in the beta.)

share|improve this answer
    
Actually, this problem appears with Firefox 3.5 on Windows, and I'm not sure about OTHER browsers, but it's probably the same... –  Ivan Vučica Jul 13 '09 at 15:11
    
Thanks, haven't tested it with FF3.5, maybe I confused this info from a Linux user's comment I saw some weeks ago. –  kd304 Jul 13 '09 at 17:27

I would say the same for altGr+B which is the '{' character on the Hungarian keyboard layout. It is the hotkey for the strong-text. Same for the AltGr+Y which is the >. It is the hotkey for the 'redo' command.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .