What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I noticed that the longer I leave stackoverflow open in a tab (because I'm so addicted) the slower it gets. So, last night I left it running overnight and checked the memory on that tab this morning to find it had climbed to over 100MB. Once I close the tab and reopen, everything is peachy again. Any ideas?

share|improve this question
    
I've had this kind of issue before in FireFox where there were Flash objects in open windows, the browser has problems freeing the memory used, or the Flash process continues to run and allocate more and more memory. I've never had a problem with SO, though I have an ad-blocker running. –  Jon Seigel Mar 16 '10 at 17:30
    
I'm up to 500mb in memory used by firefox with just SO running –  Sam Dufel Feb 24 '11 at 12:00
    
up to 1024mb used by the SO tab with Chrome Version 26.0.1410.43 m –  Bolu Mar 27 '13 at 12:20

2 Answers 2

up vote 1 down vote accepted

Do you have any extension installed?
Have you tried leaving it open on another site?

It sounds like it could be a problem with that rather than a site like this.

share|improve this answer
    
I do have extensions installed but I inspected all of tasks individually in the Task Manager utility built into Chrome. The Stack Overflow task was definitely the one with the high memory. However, I did have an extension that auto loads subsequent pages for paginated sites. I have recently removed that extension and I will monitor and update this page accordingly. –  user144709 Mar 18 '10 at 13:31
    
I haven't seen this happen since I uninstalled the FastestChrome extension. I did reinstall this extension again to verify but I think it's a newer version now and I'm not seeing the problem. Oh well, thanks for the input. –  user144709 Mar 22 '10 at 20:56
    
@ham, good to know it's been solved –  jmfsg Mar 22 '10 at 20:59

No, I haven't, and I use it everyday on Gentoo (ver 4.0.295.0 (35884)) and Arch (can't check now the version, most likely 5).

I haven't experienced leaks lately, not even with Google Wave (which crashes every now and then).

share|improve this answer

You must log in to answer this question.