What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

I am in the process of building a whole new website on my domain, and to begin with, I'd like to add OpenID delegation to it, so that I can use its domain URL to sign into OpenID authenticated websites, like StackOverflow.com.

I'm using myOpenID as my OpenID provider.

So I added this to my website <head> tag:

<link rel="openid.server" href="http://www.myopenid.com/server" />
<link rel="openid.delegate" href="http://lassevk.myopenid.com/" />
<link rel="openid2.local_id" href="http://lassevk.myopenid.com" />
<link rel="openid2.provider" href="http://www.myopenid.com/server" />
<meta http-equiv="X-XRDS-Location" content="http://www.myopenid.com/xrds?username=lassevk.myopenid.com" />

This is taken from the myOpenID website on delegation.

However, when I try to log into StackOverflow.com using the OpenID name www.vkarlsen.no, I get this StackOverflow.com error:

Unable to log in with your OpenID provider:
No OpenID endpoint found.


Edit: This works on SuperUser.com, can StackOverflow have a cache of my old, incorrect, website content?


If I try www.vkarlsen.no/default.aspx I'm redirected to a myOpenID.com page that says:

myOpenID is not authorized to verify that http://www.vkarlsen.no/default.aspx is your identifier. If it is your identifier, you can set up myOpenID to verify it. See the help page for more information.

That link goes to the same page, clearly I did something wrong.

However, and here's the fun part. If I try to log into StackOverflow.com, using the OpenID name trunk.vkarlsen.no, it then asks me if I want to associate the name with my account.

However, the files on that site is 100% exactly the same as on the main site.

C:\inetpub>fc /B wwwroot\default.aspx wwwroot_trunk\default.aspx
Comparing files WWWROOT\default.aspx and WWWROOT_TRUNK\DEFAULT.ASPX
FC: no differences encountered

The site URLs are:

  1. http://www.vkarlsen.no (production)
  2. http://trunk.vkarlsen.no (source control trunk, for testing purposes)

So, can anyone tell me what I did wrong?

Currently, the following two OpenID names are associated with my StackOverflow.com account:

  1. lassevk.myopenid.com
  2. www.vkarlsen.no/index.php?title=main_page

That second name there is from my old site, which I'm hoping I can get rid of it I can just get my new site content working.

Notes:

  1. I found this meta-question: Failure to log in with delegated OpenId, says something related to delegation was solved march 16th, however I'm having these problems today, march 21st, so I'm guessing I have a different problem.
share|improve this question
    
This sounds like a programming question, not really a Stack Overflow problem. –  Ladybug Killer Mar 21 '10 at 14:57
    
I'd be happy to move it, but since SO is the site I'm having problems with logging into, I'm betting on it being moved to superuser or closed fairly quick. –  Lasse V. Karlsen Mar 21 '10 at 17:53
    
I've now successfully associated www.vkarlsen.no with my account on superuser.com, yet stackoverflow.com maintains that there is no openid provider on my site. Can their web-retrieval software have a cache? I had some errors in my code earlier today when I first tried, so perhaps it has old content? –  Lasse V. Karlsen Mar 21 '10 at 18:00

1 Answer 1

Yes, StackOverflow currently caches OpenID discovery results. Waiting a day or so may get it to recognize the change.

share|improve this answer
    
Ok, good to know. I'll accept your answer when I've verified that it works (not that I don't trust you ;)) –  Lasse V. Karlsen Mar 21 '10 at 22:28
    
Did it work, Lasse? –  Andrew Arnott Mar 28 '10 at 3:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .