What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

I still see API links to older versions of Java, even when there's nothing relevant about that specific version. I realize that Google often links to 1.4.2 for some reason, but shouldn't we require stackoverflow users to take the time to link to the latest version of Java unless an older version is specifically being discussed?

share|improve this question
    
There's an effort out there somewhere to have a "latest" URL for the docs. I can't find it right now, but that would perhaps help to solve this. –  Rob Hruska Sep 28 '11 at 15:05
    
Found it. Disclaimer: I wouldn't have known about it if it weren't for this deleted "question". –  Rob Hruska Sep 28 '11 at 15:07
    
Man, this question is old. How come I never notice really old dates until I've actually answered/commented? :P –  Rob Hruska Sep 28 '11 at 15:08
add comment

4 Answers 4

I don't think you should require people to answer with updated links. It's their answer, not yours. If you don't like it, either downvote it, comlain about it in a comment, or write an answer with the "right" link.

There are a sizable number of API calls that haven't changed since 1.4.2 so they may still be relevant.

share|improve this answer
add comment

If there has been a subtle change since 1.4.2, it could confuse someone who doesn't realize they're looking at old documentation. But it's fairly easy to get the right version. Just type, say, "java arraylist" directly into the address bar (at least in Firefox, the way I have it set up, and probably in most browsers) and you end up at the old docs. Then change the 1.4.2 in the URL to 6 and you get the new ones.

For people with enough rep to do so, I think it's appropriate for them to change the links. I certainly wouldn't mind if someone did that to a post of mine. It might also help to popularize Java Doc Fast.

share|improve this answer
    
Only changing 1.4.2 to 6 in the URL gives a 404. You actually need to change "j2se/1.4.2" part to "javase/6". –  BalusC Apr 2 '10 at 19:07
    
Hm... it seems automatically redirect for me, at least for some classes. YMMV I guess. –  MatrixFrog Apr 4 '10 at 7:41
add comment

People link to old versions of the API, because that's what a Google search brings up:

Google search for "java runtimeexception"

Pretty much all class name searches that were available before Java 5 will bring back the 1.4.2 docs I've found.

share|improve this answer
    
That's exactly it. –  Donal Fellows Aug 24 '10 at 17:07
add comment

The main reason is the search

"java scanner"

Results in version 5, but

"java scanner 6"

Results in version 6.

Since they are virtually identical, it really doesn't matter. Unless people are linking to the docs to point out a feature only available in 6, the version they link to shouldn't matter a whole lot.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .