What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

Even after following the advice here I still can't log in to log in to my stack overflow account from my copy Firefox. This is being posted using IE (yeuch).

Every time I click on Login, then Google, it takes me straight to an inappropriate google account rather than giving me the opportunity to log in to the correct google account. I've tried getting SO to send me an Account Recovery e-mail, but when I paste that in as my OPenID URL, it just does the same as if I clicked on the google button - taking me straight to the wrong account.

This all started because I logged out of Stack Overflow and the next time I tried to log in, accidentally used the wrong google userid. Now it seems to be stuck with that ID, even when I explicitly tell it to use another one.

Otherwise, nothing has changed here firewall wise, I haven't changed my coockie policy and I have cleared my SO cookies in FF, all to no avail. Trying in another borwser was the only way to get it to work.

Any thoughts?

share|improve this question
    
i think your problem is an existing Google cookie, not an SO cookie, in FF. try clearing that. (i recall this coming up before but i'm not finding the earlier question. i could be misremembering.) –  quack quixote Mar 23 '10 at 19:55
    
Yup, that makes sense. I didn't want to clear all cookies, so I cleared the SO ones. I didn't even think that SO would be looking at my google cookies. *8') –  Mark Booth Mar 23 '10 at 20:27

2 Answers 2

up vote 2 down vote accepted

Have you tried logging out of your Google account? I just tried logging in and out, and if I'm still logged in to my Google account it doesn't give me a choice.

share|improve this answer
    
Thanks @Josh K, that seems to be what trying the diagnostics page forced me to do. –  Mark Booth Mar 23 '10 at 20:01

Ok, I worked out what to do.

Just using the diagnostic page to test the OpenID which the Account Recovery e-mail gave me seemed to stop Firefox from trying to use the incorrect one, allowing my to log in with the correct account the next time I tried to log on to SO.

I'm still not sure why just clearing cookies didn't do the job, but at least it's working now.

Edit: I feel bad about correcting disgnostic to diagnostic now *8')

share|improve this answer
1  
disgnostic is my new favorite word. dis- lack of, away from; gnostic knowing. –  quack quixote Mar 24 '10 at 22:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .