Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

A meta.SE bug came up which also applies to SOFU.

Any URL path ending in a dot produces a low-level server 404, rather than the usual SO 404, even when the dot is part of a string which is supposed to be ignored.

Shouldn't the URLs be sanitized before they are processed so that special characters are treated as literals?

share|improve this question

closed as off-topic by Ilmari Karonen, Martijn Pieters, Josh Crozier, hims056, Lucifer Jan 19 '14 at 12:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "The problem described here can no longer be reproduced. Changes to the system or to the circumstances affecting the asker have rendered it obsolete. If you encounter a similar problem, please post a new question." – Ilmari Karonen, Martijn Pieters, Josh Crozier, hims056, Lucifer
If this question can be reworded to fit the rules in the help center, please edit the question.

2  
Related: meta.stackexchange.com/questions/40131/… – Helen Mar 29 '10 at 19:10
2  
I can't believe you rolled back my edit, @Downvoter. That was a very relevant question. – mmyers Mar 29 '10 at 21:18
1  
It was already there in the question @mmy! – juan Mar 30 '10 at 0:07
up vote 6 down vote accepted

I believe this is a bug deep, deep in the .NET framework. Seriously.

See:

http://stackoverflow.com/questions/2515959/how-to-create-a-uri-instance-parsed-with-genericuriparseroptions-dontcompresspath

and related connect item, System.Uri incorrectly strips trailing dots

https://connect.microsoft.com/VisualStudio/feedback/details/386695/system-uri-incorrectly-strips-trailing-dots?wa=wsignin1.0#tabs

share|improve this answer
2  
Are we inventing [status-framework-fault]? – Tyler Carter Mar 30 '10 at 3:02
1  
[status-byframeworkdesign] – Gnome Mar 30 '10 at 3:55

This bug has been fixed. Now:

share|improve this answer

Not the answer you're looking for? Browse other questions tagged .