What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

I get this error when trying to login to stackoverflow via OpenID (blogger.com is the provider):

Unable to log in with your OpenID provider:

The following required non-empty parameters were empty in the DotNetOpenAuth.OpenId.Messages.PositiveAssertionResponse message: openid.invalidate_handle

Firefox 3.6.3, no custom cookies config, tried clearing cookies, etc.

share|improve this question

3 Answers 3

up vote 3 down vote accepted

Blogger has some incorrect behavior w/r/t OpenID so we have to run a custom build of DotNetOpenAuth that allows for it.

We lost that custom build in the last deploy, but I just re-deployed with the fixes reinstated -- it should work now.

I'll try to get Andrew to make this "relaxing" part of the main trunk as a configuration option, that way it won't get lost again when new versions are released.

share|improve this answer
    
thanks for fixing it. –  tobsen Apr 17 '10 at 19:50

I have the same problem. I managed to add a gmail openid with a browser where I was still logged in, and that seems to work.

share|improve this answer

I'm experiencing the same problem in Chrome beta (5.0.342.9). I've worked around it by adding my Google profile as an alternate OpenID provider, the URL for that is: http://www.google.com/profiles/<USERNAME>

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .