What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

What steps will reproduce the problem?

  1. click on "What programming languages do you consider indispensable in your experience?"

What is the expected output? What do you see instead?

Expected content of the page. Got "HTTP Error 404. The requested resource is not found."

"View Page Source" shows that the correct page is returned (only status code is invalid).

Software versions

Firefox 3.6.3 Ubuntu 10.04

It might be just a temporary glitch

share|improve this question
1  
@Jeff, it is a temporary glitch indeed, and has happened to me as well, for other questions on the trilogy. A refresh always fixed it right away; I've yet to see the same error when refreshing. A bit hard to troubleshoot, unless the access logs somehow show a 404 for the URL from this question? The 404 is a SOFU error page, not some browser message. (Adding this to my favourites to post URLs if it happens to me again.) –  Arjan May 8 '10 at 13:49
1  
A View Source in Firefox actually requests the page again, so I guess that explains seeing the question when doing View Source. Other browser show the source of the page as it's currently shown. –  Arjan May 8 '10 at 13:51
    
By the way, @Jeff: I think I've only seen this when clicking an item in my browser's history, and never when following a link from a SOFU homepage or (Google) search results. Hence, maybe it's related to some session thing? (Surely, following an old edit link from the browser history, like posts/49262/edit-submit/d1b73e31-d806-4f7d-aa4c-900112b952ff, gets one an error too, but that's not what I'm referring to.) It's not a new issue; I've seen it before and indeed one time today as well if I recall correctly... –  Arjan May 8 '10 at 14:36
    
J.F., did you post this question soon after it happened to you? (To give the crew some timeframe, to see if it indeed might have been caused by some update after all -- and hence status-norepro might indicate: meanwhile solved.) –  Arjan May 8 '10 at 18:17
    
@Arjan: I've posted in ~5 minutes after it happened. –  J.F. Sebastian May 10 '10 at 2:56

1 Answer 1

In the lower-right corner, a version number is shown, like revision: 2010.5.8.6. If after a browser refresh the first part is today's date, then a new version might just have been deployed.

share|improve this answer
    
I've seen that happen a couple of times; I think it happens when they push an update or something like that. –  balpha May 8 '10 at 18:07
    
Yep, we just deployed a new version - there can be a few 404s depending on how unlucky you are. –  Geoff Dalgas May 8 '10 at 18:13
    
Aha, next time, if I happen to still have another window open, I'll look at the version number in the lower-right corner, or peek into the HTML to get the version numbers (like from <link rel="stylesheet" href="http://sstatic.net/mso/all.css?v=ee971a626dcf">), and compare those to the values from a refreshed page... –  Arjan May 8 '10 at 18:14
    
@Geoff, do you still want us to post here, if it happens again in the coming weeks? Or are you confident it's always due to some maintenance? (And: does it matter if it is a very basic message, or a nice 404 page?) –  Arjan May 8 '10 at 18:19
    
Ah, that revision in the lower-right corner is actually a date, like revision: 2010.5.8.6 :-) (So, I changed my answer.) –  Arjan May 8 '10 at 18:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .