What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

When I browse SO and sister sites I keep getting logged out and have to login again every 10 minutes or so. My issue is similar to Keep getting logged out of StackOverflow today. However, that problem was fixed back in March.

This only happens when browsing from my work computer. I'm using IE 8 and I'm inside a corporation with a lot of security measures including a firewall that is pretty strict about browsing. I have looked at the cookie on my computer and it seems to be fine. (It exists and is set to expire in the far future.)

Voting, commenting and answering is pretty broken at times if I have to login during the process. I often end up creating multiple items and have to login again and delete the duplicate item.

Even though this may be an issue on my side I generally don't have any problems browsing the internet from my work computer. E.g., My OpenID provider (Yahoo) keeps me logged in for extended periods of time and repeatedly performing a login to SO only requires a few clicks.


Update

I've been playing around with Fiddler2. When I login I see this sequence of events:

  • => GET /users/authenticate
  • <= 302 Found, Set-Cookie: (stackoverflow cookie)
  • => Get /, Cookie: (stackoverflow cookie)
  • <= 200 OK

When I refresh that front page I see this sequence of events:

  • => Get /, Cookie: (stackoverflow cookie)
  • <= 407 Proxy Authentication Required (The ISA Server requires authorization to fulfill the request. Access to the Web Proxy service is denied.)
  • => Get /, Cookie: (stackoverflow cookie), Proxy-Authorization: (some stuff)
  • <= 407 Proxy Authentication Required (Access is denied.)
  • => Get /, Cookie: (stackoverflow cookie), Proxy-Authorization: (some stuff)

I see the same sequence of events both when I don't have to login and when I have to login. The cookie is set by my browser in both cases.

It is probably the ISA server that is the source of my problems. However, as far as I can see the SO cookie is always preservered and I don't understand why I have to login even when the cookie is sent. Perhaps SO does some additional verification of my login that fails because I'm behind an ISA server?

Perhaps this also explains why posting stuff to SO can create duplicate items. The cookie is included in the request that is partly succesful, and after being redirected through the login page the same request is sent a second time. This is of course speculation on my behalf.


Another update

Apparently my problems has disappeared, at least I havn't experienced the problem for the past several hours. I don't know if it is change on my side or on SO's, but so far I'm happy. :-)

share|improve this question
    
I have this same issue, though less frequently (ever 30 minutes or so). Firefox and Chrome--latest versions, whatever those are. –  James McNellis Jun 18 '10 at 13:51
    
10k users can use meta.stackexchange.com/questions/54161/… as a demonstration of this duplication. –  Grace Note Jun 18 '10 at 14:11

1 Answer 1

As far as I noticed,

Stack Overflow cookie have 2 parts - "t" and "s", "t" is updated periodically, may be around 5 or 10 minutes. If that Set-Cookie part is missed to set or get blocked, unmatched "t" and "s" values cause the user logout.

share|improve this answer
    
Can you provide me with some hints about how I can troubleshoot that particular issue on my work computer? –  Martin Liversage Jun 18 '10 at 14:21
    
@Martin, could you moniter http headers and moniter for Set-Cookie parts? I guess, its getting dropped before it reach your browser or fail to set on browser. –  YOU Jun 18 '10 at 14:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .