Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 157 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

In WinXP + FF 3.6.3 and 3.6.4, all I get is a grey box. There's nothing to drag around, just a background image.

This means that when I search, the default search radius of 20 miles is always applied. This, of course, can be corrected manually in the URL's querystring, but that's not how it's supposed to work, I assume.

alt text

EDIT: Is it possible this UI piece is pulling scripts from a site I've blocked? I'm running NoScript in Firefox.

EDIT: Okay, it's not NoScript. I disabled it, and same thing. I did a bit of testing with FireBug and it looks like a JavaScript issue.

share|improve this question
    
Note also: the UI is the same regardless of what is in the "where" text box. – Jon Seigel Jun 24 '10 at 19:37
2  
Are you using AdBlock perchance? – Jason Punyon Jun 24 '10 at 20:37
    
@Jason: Yes. Here are all my addons: Adblock Plus v1.1.3, Firebug 1.5.0, Greasemonkey 0.8.20100211.5, Java Console 6.0.18, Java Quick Starter 1.0, MS .NET Framework Assistant 1.0, and NoScript 1.9.9.47. – Jon Seigel Jun 24 '10 at 20:49
up vote 8 down vote accepted

We can reproduce the problem with Ad Block on our end, after a smart bit of detective work by Jason.

We're running "ads" on the right-hand side, and when they are blocked, it seems to stop the execution of other stuff. I've made a change so that ads load last, which should mitigate the issue -- we'll go live with it tomorrow.

share|improve this answer
    
Okay, yes, if I disable AdBlock, the slider works. Good sleuthing! (Will upvote when I get more votes in 3 hours.) – Jon Seigel Jun 24 '10 at 20:52
    
This works for me now with AdBlock enabled. Thanks! – Jon Seigel Jun 25 '10 at 14:54
1  
Thanks for the confirmation. – Matt Sherman Jun 25 '10 at 19:17

Maybe it's time to upgrade your browser...

That said, it should probably have a text box or radio buttons when nifty ajaxy stuff isn't available due to a browser being old and busted.

share|improve this answer
    
Old and busted? FireFox 3.6.4 only came out two days ago... – Grace Note Jun 24 '10 at 19:15
2  
I LOL'd. That being said, I upgraded to 3.6.4, and it's still broken. – Jon Seigel Jun 24 '10 at 19:16
    
@Jon Seigel: it definitely works on FF3.6.3/Win7, and Chrome5/Win7 – Randolpho Jun 24 '10 at 19:36
    
@Grace Note: it was a joke, son! – Randolpho Jun 24 '10 at 19:39
3  
@Randolpho: Wow. I just tried using IE6 (default install with XP), and while the layout is completely busted, the slider works perfectly. hahahaha – Jon Seigel Jun 24 '10 at 19:40
    
@Jon Seigel: either the problem is your particular setup in Firefox, or some bug in Firefox that only presents itself on WinXP. Maybe it's time to upgrade your OS.....:) – Randolpho Jun 24 '10 at 19:49
    
@Jon Seigel: Your ABP and Firebug are out-of-date as well. – Gelatin Jun 24 '10 at 21:22
    
@Simon: Thanks for letting me know. – Jon Seigel Jun 24 '10 at 21:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .