Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

When attempting to save changes made the "About Me" section of my Stack Overflow profile while using an iPad, I encountered this error:

Oops! There was a problem updating your profile:

  • unusual error updating your profile - please try again!

I was able to edit and save my profile a few moments later on my desktop without a problem. I tried once more with the iPad with the same error coming up.

My updated profile includes HTML and is maybe 300 or so characters in length. When I attempted to save my profile a second time after having changed it on my desktop, I simply clicked Save Profile without making any changes.

share|improve this question
Does this occur with any changes at all? Or is it a specific change or set of changes? – Grace Note Jun 29 '10 at 3:26
@Grace: Updated my post. Hopefully it's a bit more clear. – Paperjam Jun 29 '10 at 3:33
Very nice and much clearer. Thanks! I hope this helps identify the source of the unusual error. – Grace Note Jun 29 '10 at 3:36
I also see this problem. – Zoredache Jun 29 '10 at 7:54
Questions about iPad are off-topic on Super User, voting to.... erm, sorry. – Gnoupi Jun 29 '10 at 8:28
This also appears to be happening on the iPhone, reported here:… – Grace Note Jul 6 '10 at 17:55

This was an issue in some specific javascript we embed for mobile devices - a fix will be pushed tonight.

share|improve this answer
Thanks Jarrod. I can confirm this is now working on my iPhone. – Andy E Jul 7 '10 at 9:40
Unfortunately, I still get the same "Oops..." error that started this thread. I am using an iPhone 3G running iOS 3.1.2 and accessing the site from Safari. I would update to iOS 4.0.2, but that would break the unlock of my phone. I will update my user info from my laptop the next time I'm at an internet cafe, but it would be nice to see this fixed for the next user who tries using it. – user150913 Sep 5 '10 at 1:39
@user150913 a javascript refactoring broke this again; a fix is being pushed tonight. – Jarrod Dixon Sep 6 '10 at 4:55

I had this error, but not on an iPad (I own no Apple products).

I run NoScript on Firefox so that I can whitelist JavaScript from trusted sources. I found I got this error until I allowed access to — then the relevant scripts could run and the profile was updated.

If anyone runs across this error on a desktop, this may be the cause.

share|improve this answer
that's definitely related, thanks for sharing the tip with others – Jeff Atwood Mar 23 '11 at 10:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .