What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 129 Stack Exchange communities.

Logged into day to see the Organizer Badge for myself, but the question it is linked to gets a Page Not Found: How should versioned jQuery tags be combined on stackoverflow?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

The question was deleted.

Please see this question for further discussion.

share|improve this answer
    
Thanks. I wish it has been closed/locked so I could get back my research. –  Kevin Hakanson Aug 11 '10 at 2:50
    
@Kevin: I posted the content from the question in a separate answer here. I've also voted to undelete the question. –  Jon Seigel Aug 11 '10 at 2:55

Deleted content:

By Kevin Hakanson (question body):

I was looking at jQuery related tags and noticed the last two major versions account for five separate tags: jquery1.3 (32), jquery1.4 (18), jquery1.3.2 (8), jquery-1.3.2 (4) and jquery-1.4 (3)

Since the Official repository of tag synonyms seems to the product-x.y format, I would suggest merging into jquery-1.3 and jquery-1.4, but I wanted to open for discussion. Also, should this be added to the tag synonyms list?


By Nick Craver (answer):

I would recommend against merging the minor releases, there are issues in each release, for example a common question is about the change event not bubbling in IE (causing .live('change', func) breaks). This issue is specific to 1.4.1 and fixed in 1.4.2 (along with many event questions).

I would recommend mapping:

Personally I would leave the minor releases intact, this would result in jquery-1.3, jquery-1.3.2, jquery 1.4, jquery 1.4.1, and jquery 1.4.2.

That being said, leaving only jquery-1.3 and jquery-1.4 wouldn't be all that bad, but the vast majority of questions aren't tagged with a version at all (something I'll start doing in future edits).

Update: I moved the jquery1.x.x tags to jquery-1.x.x to at least normalize the formatting for now, there are still a number of jquery1.3 and jquery1.4 out there that need a bulk retag.


Comments on answer:

Why would we merge jquery14 with jquery1.4? I thought we wanted to keep major releases separate. – devinb Jul 19 at 18:50

@devinb - jQuery14 is 1.4...1.4 is the latest release, there's no jQuery 14 out there :) – Nick Craver Jul 19 at 18:53

I see your point about minor versions affecting the question, but doesn't this better fit in the question text and not the tag? – Kevin Hakanson Jul 25 at 3:17

@Kevin - I don't think so, my opinion again of course...when I see certain issues I would immediately recognize the issue as a known bug in that version, I would tag questions with those issues with that minor version as well...to indicate it's specific to jQuery-1.4.1 Often the issue doesn't apply to jQuery-1.4 overall, and most people being on the latest (of 1.4 users) wouldn't be affected. That being said, I may be one of 5 people max that this really helps, if it doesn't help anyone else to find answers then let's cleanup/combine them, and leave the minor versions out. – Nick Craver Jul 25 at 12:26

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .