Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I'm using a delegate for MyOpenId, and over about the past day, I've encountered the "Unable to log in with your OpenID provider: No OpenID endpoint found." error when trying to log in. I can log in with Google, but I still hit this problem even if I haven't already logged in to Google and I don't think of that as a permanent solution anyway.

I just finished a torrid time of determining how to make my delegate OpenID work with StackExchange sites, so I don't know what could be the cause this time. Immediately afterward, I tried logging into slashdot and SourceForge, both of which support OpenID authentication, and both signed me in without a problem.

On my OpenID delegate page, I have the following in my <head> tag:

<link rel="openid.server" href="" />
<link rel="openid.delegate" href="http://[OPENID]" />
<link rel="openid2.provider" href="">
<link rel="openid2.local_id" href="http://[OPENID]">
<meta http-equiv="X-XRDS-Location" content="[OPENID]" />

What am I missing?

share|improve this question
up vote 1 down vote accepted

Works OK for me when I enter -- I get sent to myopenid.

I suspect your server is too slow to return data overseas at times; there are some timeouts to prevent denial of service login attacks (by entering thousands of bad "extra slow" openids).

You might try

  1. measuring response time to your website from various sites
  2. Putting the openid stuff on a nearly blank page which has FAST load time

also see:
Can't log in with my OpenID - Troubleshooting Tips

share|improve this answer
Yeah, it works for me now, too. It was just a weird, 1-day error I guess. But, slowness didn't seem to be an issue for me, at least, because I visited my page and it loaded without any speed issue. – palswim Sep 13 '10 at 15:37

I've probably solved at least part of the issues. It turns out that my site has been having DNS issues, about which I didn't know. I don't know if it has fixed all of the OpenID issues I've had, but it certainly fixed the current one(s).

share|improve this answer
+1 for not dangling prepositions. – Thunder Rabbit May 7 '12 at 11:12
Thunder Rabbit ~what are you talking about ? – violet313 May 9 '12 at 16:35

i had the same problem with some less used stackexchange side in mai 2012. i was not able to login to using any more.

accessing had very slow response- i got the answer after 22 seconds.

fortunately i had some local login-cookie for some other stackexchage site where i was still logged in. there i was abel to go to my account and added a second openid for my account.

now i am using this second openid to connect to

this way i have a backup account so i donot loose my stackexchange reputation when one openid-provider goes offline

share|improve this answer

I found out that accidentally leaving out the <html> opening tag also yields the "No OpenID endpoint found" message when you use OpenID delegation. This is true for the DotNetOpenAuth library that Stack Overflow uses.

On the other hand, if the HTML is valid, the delegated OpenID login works even if only these two lines are to be found in the HTML header (for Google account in this case):

<link rel="openid2.provider" href="">
<link rel="openid2.local_id" href="[YOUR-ACCOUNT]">
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .