What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

A search for "type-punned" on Stack Overflow takes me to the URL

http://stackoverflow.com/search?q=type-punned

Which lists a question "strict aliasing" and provides the link

http://stackoverflow.com/questions/754929/strict-aliasing

but that link just gets me a message from Stack Overflow:

“Sorry, that page doesn't exist!”

Other questions still "exist" but this one persistently doesn't.

So, is this a bug? Poorly explained feature?

share|improve this question
    
I voted to undelete it because I see no reason as to why it was removed. –  jjnguy Jul 17 '09 at 14:15
    
(undeleted; see answer for details) –  Marc Gravell Jul 17 '09 at 14:27
add comment

2 Answers

The question was deleted on July 8th. References to it are still lingering though.

If you have 10k rep you can still see the question.

share|improve this answer
    
OK, in that case it seems like a bug that you can still get handed it as a "search result" ten days later. Maybe it's a hard to fix bug, but it's a bug. –  tialaramex Jul 17 '09 at 14:18
    
BTW I don't have 10k rep on Stack Overflow yet. Could take me a few years at my current rate. :) –  tialaramex Jul 17 '09 at 14:19
    
There is no hurry. It isn't that special... –  jjnguy Jul 17 '09 at 14:28
add comment

It looks like the user that created it was "destroyed", which deletes any questions / answers / comments etc that they've made.

The question itself seems sound; undeleted.

Update... hmmm; it looks like it may have been me that destroyed the user... I'm 100% confident that I had a good and valid reason... no idea what it was, though.

From the logs:

Marc Gravell -> Moderator destroys user for id = [redacted] by Marc Gravell - Jul 8 at 7:58

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .