What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

In this SO post, the hyperlink is shown incorrectly in my browser (Firefox 3.6.10, WinXP SP3):

alt text

Interestingly enough, it is displayed correctly in the editor preview:

alt text

share|improve this question
1  
This will likely go down as [status-bydesign] because it's essentially malformed input. –  Jon Seigel Oct 15 '10 at 16:51
1  
If it is typed into the URL dialog, it should be escaped, so this should be considered a bug –  Adam Oct 29 '10 at 18:09

2 Answers 2

up vote 3 down vote accepted

Don't know why it shows up properly in the preview, because it shouldn't: that URL is bad.

http://download-llnw.oracle.com/javase/6/docs/api/java/lang/Integer.html#rotateLeft(int, int)

It contains a space, and as indicated in this recent report, it will cause the URL parser to treat the footer as normal text. In this scenario, though, the solution is to escape the space. And as noted in a few other questions like here, the parentheses might need to be escaped as well; I'm not quite sure since the footer syntax doesn't use parentheses.

share|improve this answer

While, as Grace notes (no pun intended), the URL illegally contains a space and hence shouldn't display correctly, you're right in so far that it should look just as broken in the preview.

This will be the case after the next build.

share|improve this answer
    
Lies, that pun was totally intended. –  Andy E Jan 6 '11 at 12:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .