Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 157 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

The behavior of the StackExchange™ MultiCollider SuperDropdown™ is different before and after the page fully loads.

While page is loading: Links to StackExchange.com

After page load: StackExchange™ MultiCollider SuperDropdown™ (Showing inbox if you have new items)

This becomes a bug when you have a new notification in your global inbox, and you click on the SE logo, and instead of showing your inbox, it directs you to StackExchange.com.

share|improve this question
3  
+1 This is is ridiculously annoying. – Jonathan. Oct 31 '10 at 17:45
    
+1, how did you even notice this? – Pops Nov 3 '10 at 15:08
    
@Popular, if I have a new notification, it shows the red circle, and I usually check those as soon as I get them. So, sometimes I end up clicking it before the page is done loading. I blame it on my slow internet connection. – jjnguy Nov 3 '10 at 15:13
up vote 7 down vote accepted

After the next build, clicking the MultiCollider will only take you to http://stackexchange.com if you have JavaScript disabled.

Otherwise, clicking it (even very early) will cause the regular popup to show up, possibly with a short delay (i.e. only as soon as the page is ready for that).

share|improve this answer
    
Fantastic, thanks. – jjnguy May 10 '11 at 12:20
1  
cough. :-( – Shadow Wizard May 7 '14 at 8:42

I agree this is a kind of bug and IMHO this behaviour isn't what unobtrusive JavaScript should look like. This is especially annoying when behind a slow/flaky connection, as I am now. Every time I see the red number on top of the page I'll have to be aware that I have to wait until the page is fully loaded and because of the flaky connection I'll have to wait even longer before I'm back on the previous page.

I think the StackExchange™ MultiCollider SuperDropdown™ should be disabled (greyed out) or even invisible while the page renders and added or activated by the JavaScript that adds the dropdown behaviour.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .