What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

I'm logged into several SE sites and in the past chat did worked for me. However since some time it refuses to log me in stating I'm not logged on any SE site. I've tried both with Fx and WebKit Epiphany.

There is no problem with tavern.

Edit: After logging out everywhere and logging in on SE site pressing log in in chat it says that my data auth is too old as oppose to previous behavior of logging indefinitly.

Global auth stopped working about the same time.

share|improve this question
    
What is "Fx" and "WebKit Epiphany"? We support: IE, Firefox, Chrome, Safari, and Opera when possible. Anything else is use at your own risk. –  Jeff Atwood Nov 8 '10 at 2:26
1  
This was discussed on chat.MSO for a bit. (Fx = Firefox) –  Rebecca Chernoff Nov 8 '10 at 6:32

2 Answers 2

This seems to be a bug in Epiphany; it's sending invalid invalid requests in certain edge cases. These requests are rejected by the server. We may be able to implement a workaround; until then, I'm afraid you have to use a different browser.

I have filed a bug against Epiphany regarding this issue.

share|improve this answer
    
Hmm. How would bug in Epiphany affect Firefox? –  Maciej Piechotka Nov 10 '10 at 14:03
    
@Maciej Piechotka: Are you using a recent version of Firefox? It appears older version of FF had the same problem. Also, please check if our new GlobalAuth Help & Test page finds any issues. –  balpha Nov 10 '10 at 14:06
    
@balpha: I've had similar problems (chat works for SO, SU, and SF, but never worked for SX) with Firefox 3.6.12 on Mac OS Tiger, although I haven't been diligent about flushing all login info, so I can't rule out corrupted session data on my side. –  Charles Stewart Nov 10 '10 at 14:40
    
@balpha: 2.6.12 - so the newest stable. –  Maciej Piechotka Nov 11 '10 at 13:26
    
@Maciej Piechotka: I assume you mean 3.6.12. What are the results of the test page? –  balpha Nov 11 '10 at 13:47
    
@balpha: Link to test is broken. –  Maciej Piechotka Nov 13 '10 at 3:31
    
@Maciej ah yes, we changed the route yesterday. chat.stackexchange.com/help It's also linked from the login page. –  balpha Nov 13 '10 at 6:53
    
@balpha: Both passes. –  Maciej Piechotka Nov 13 '10 at 18:12

I assume it was chat.MSO or chat.SO that worked? chat.SE uses a different login, that is more dependent on the single-sign-on. I'll update the login page, but this in turn is mainly interested in when you logged in.

So try logging out completely from your preferred site, and log back in. Then go to chat.SE. Please do let me know either way.

share|improve this answer
    
I've logged out from SE, SO etc. –  Maciej Piechotka Nov 8 '10 at 13:09
    
@Maciej - and what happens? does chat.SO work? does chat.SE work? –  Marc Gravell Nov 8 '10 at 13:37
    
@Marc: chat.SO always worked. char.SE still does not work (instead of loading indefinitly it displays message about too old auth). –  Maciej Piechotka Nov 8 '10 at 13:52
    
@Maciej - it sounds like the localstorage hasn't cleared. Can you try a "log out everywhere"? Sorry to be a pain, but I can't repro from here... it keeps working :( –  Marc Gravell Nov 8 '10 at 13:53
    
@Marc: No problem. I reproduce the correct behaviour on Chrome. I'll try Linux next. –  Maciej Piechotka Nov 8 '10 at 19:24
    
@Marc: It works now on Windows but it won't on any browser on Linux. –  Maciej Piechotka Nov 9 '10 at 10:46
    
@Maciej - which *nix? I'm firing up my dual-boot ubuntu 10.10 to check a few... –  Marc Gravell Nov 9 '10 at 11:13
    
worked perfectly in Chrome –  Marc Gravell Nov 9 '10 at 11:15
    
I wonder if you have something getting blocked by noscript? –  Marc Gravell Nov 9 '10 at 11:16
    
worked perfectly in FireFox 3.6.11 –  Marc Gravell Nov 9 '10 at 11:17
    
installing Epiphany... –  Marc Gravell Nov 9 '10 at 11:18
    
@Marc: Gentoo. Evenrything unlocked. It worked before and I haven't done any update of Fx. –  Maciej Piechotka Nov 9 '10 at 11:19
    
indeed it fails on epiphany; we'll look into that to see if there is a simple fix –  Marc Gravell Nov 9 '10 at 11:23
    
Any update? It still does not work on Firefox. –  Maciej Piechotka Jan 1 '11 at 16:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .