Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

Update Okay, I still get this behavior, but it has something to do with this instance of Chrome vs. another. Which likely implies it has to do with cookies or something.
I realized this after starting chrome with another profile.

It seems to me that cached and recent content works fine, but I haven't been able to — for example — load this question all day today. Also, the markdown editor isn't working here, and I can't load any of the actual rooms on Merge this if someone else is talking about the issues.

PS I'm on Chrome in a building full of networks in NYC.

 7 (  1.558 ms  1.477 ms  1.672 ms
share|improve this question
Thanks for sharing. 14 hops, 70 msec from the MidWest. Every time I checked. I'm not often pleased with my ISP. – Uphill Luge Nov 9 '10 at 1:36

Are you having trouble getting to the CDN at ? We can't reproduce this.

share|improve this answer
I can also no longer reproduce this after restarting that particular instance of chrome. The behavior seemed to be as though scripts would never complete loading. I didn't get to test if I had an issue with, but the odd thing is, the other browser running when I did have the issue had no problems. – dlamblin Nov 9 '10 at 15:38

If your ISP (or building or something) is blocking any content, you may be experiencing issues from that. At work they block things like Gravatar, Google Analytics, and things like that which do cause some issues for me on the SE sites. Could that be part of the problem? Possibly adblock might have an effect?

The page keeps spinning and spinning for about 30 seconds after it loads. I presume that something that is being retrieved is in the process of timing out.

Does your page load at all?

share|improve this answer
Thanks; the pages actually seemed to load most of the content, but never get around to rendering for older questions... questions of the day worked fine. I admit this is baffling. – dlamblin Nov 9 '10 at 15:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .