What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

When I try and login (today) on http://odata.stackexchange.com/stackoverflow/queries and choose my open id provider (myopenid) it tries to auto log me in before I can even type my username (subdomain)... thus I get logged in as John Doe 52 or something like that.

I get the feeling that the value in my local/session storage might have been wiped.. but the key is still there? (not sure how I can easily check in Firefox/Firebug). If so, it seems like the code should be a bit more robust to ensure that the stored username or whatever is stored is != "".

I'm fairly sure this has worked in the past as I have created several queries.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

Did you go to the logout page (on a SE 2.0 site, not sure if SEDE supports this) and click "Log Out Everywhere"?

That will clear HTML 5 Local Storage, and thus your network login.

share|improve this answer
    
hmm, tried that... logged out everywhere... re-logged in on Stackoverflow... then here... tried SEDE... no luck. tried to login on SEDE and I get the error "Message signature was incorrect" (after it tries to auto log me in... and if I manually type my open id url and click login. –  scunliffe Nov 13 '10 at 23:13
    
@scun might be a bug in SEDE –  Jeff Atwood Nov 13 '10 at 23:16
    
hmm, ok, no worries... I'll give it a re-go tomorrow, thanks @Jeff. –  scunliffe Nov 14 '10 at 0:56

I've been having trouble too, very similar to yours. Couldn't get past "Message signature was incorrect" when trying to use my regular provider (myOpenId). Tried Google next which failed with a 404 on my assigned user ID page. The next attempt worked. I did end up with a different user name though. Google's, not the one I get through the myOpenId login. SEDE is, erm, different.

share|improve this answer
    
is login to data.se working now for you? –  waffles Mar 28 '11 at 2:55
    
@waffles - sorta, I'm jon.doe60 there. No idea how to reset it, it doesn't matter much afaict. While I got your ear, how do I reset the saved query parameter default? I'm getting the wrong user ID on every query, resetting cookies didn't help. –  Uphill Luge Mar 28 '11 at 12:24

I also have an unusual problem when using OpenID. I get my open id through my ISP. But if I'm logged into my ISP through a different subaccount, I can't log into a new SE site, because it automatically picks the wrong OpenID.

So I have to log out at my ISP, log into the subaccount I use with SE, log into SE, and log into the new (to me) SE site. I only have to do this once. Once I've logged into a site, I can access that site even when I'm logged into my ISP on the wrong subaccount.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .