What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 128 Stack Exchange communities.

I have an account on Stack Overflow with a MyOpenID account. I have not logged in for a while, so I am not sure when it broke. But when I login now I get this:

Unable to log in with your OpenID provider:

Error occurred while sending a direct message or getting the response.

share|improve this question
    
I tested both IE7 and Firefox 3.6.6 –  Michael Dec 6 '10 at 20:21

2 Answers 2

Note that if you have a period in your MyOpenID "username", such as

awesome.dude.myopenid.com

you must log in by typing in your URL, do not click the MyOpenID button.

It's a long story, but MyOpenID royally screwed up by allowing early users to put periods in their names. Why?

https://dude.example.com

requires a different SSL certificate than

https://awesome.dude.example.com

They no longer allow period in names (they force dashes instead), but early adopters might have them. Long story short, if you have a period in your MyOpenID username, you MUST type in your login manually in the login form. Clicking the "log in with MyOpenID" button will not work for you. Note: even if you type in your login manually it will only work if JavaScript is allowed from myopenid.com. This can happen with JavaScript whitelisting, as with Firefox and NoScript.

Yes, this is a bug that can be worked around on their end (not our end), but I can't get anyone to fix it despite repeated emails to JanRain.

share|improve this answer
    
+1 for the royalty. could do with some citation. –  abel Jan 6 '11 at 10:17
    
This is really, really frustrating. I spent 15 minutes trying different combinations to log in, before I fell across this d*** post. –  Remi Despres-Smyth Jan 20 '11 at 15:28
    
@remi I feel your pain, I have been nagging them to fix this for months but no love. –  Jeff Atwood Jan 20 '11 at 19:10
1  
@Jeff FYI, I got a reply on Twitter from @Janrain re:this post: "Remi, update for you. We implemented a workaround in Janrain Engage to enable myOpenID sign-ins for this use case.", followed by "This problem only persists for sites using myOpenID button natively & unfortunately we can't control the transaction for these sites". Whatever they did didn't make it any less frustrating when I was logging in yesterday, though. –  Remi Despres-Smyth Jan 21 '11 at 18:40
1  
@remi that's basically "we will fix it for our paying customers, but nobody else." (oh, and this is totally under their control; I have no way of fixing it at all) Really not happy with them of late. –  Jeff Atwood Jan 22 '11 at 0:53
    
That seems like incentive to drop active support for myOpenID and/or encourage migration away from them. Perhaps burring the button under "More Options" would punish them enough and a mass e-mail to all the StackExchange users with a period in their name, and directing them here, would clue some people in. –  CodeSlave May 25 '11 at 16:57
    
@code this has effectively already happened, see blog.stackoverflow.com/2011/05/… –  Jeff Atwood Jun 22 '11 at 22:13
    
@Jeff I see that... at the time I was hoping that I had prompted that post, but I guess not :) –  CodeSlave Jun 23 '11 at 18:19
    
@Jeff Atwood: I did some troubleshooting and found JavaScript must be allowed from myopenid.com in order not to get "Unable to log in with your OpenID provider: Message signature was incorrect." (when using the manual option). I have added a note to your answer. –  Peter Mortensen Jul 23 '11 at 13:30
    
@peter interesting, I was not aware of that -- thank you for the clarification! –  Jeff Atwood Jul 23 '11 at 20:47

I'm in this situation, and was unable to log in. I read this, and saw the tip about entering the URL, but it took me a while before finally clicking on the "More OpenID options" to get to the manual entry. Then it worked fine.

It would be nice if there were some way to show that input field more automatically.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .