What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

Stack Overflow and Meta Stack Overflow prompts me that "Stack Overflow works best with JavaScript enabled". But I reconfirmed that I have my JavaScript enabled by default. I am using Firefox 3.6.

share|improve this question
    
Not confirmed on Firefox 3.6 on Windows. Are you sure you have no local setting enabled to turn JS off? –  Pëkka Dec 12 '10 at 2:54
    
no but everything is working fine apart from the prompt –  biju Dec 12 '10 at 2:59
    
I refreshed page again, it went away. –  Mowgli Jul 2 '13 at 20:12

3 Answers 3

up vote 6 down vote accepted

This could be caused by Google's CDN being blocked, and hence its jQuery not being available:

<script type="text/javascript"
  src="http://ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js">

For some time, the JavaScript also outputted “Stack Overflow works best with JavaScript enabled” when jQuery was not loaded. In March 2011 it became more specific:

// display a warning (like the noscript warning) even if JS is enabled, but
// jQuery isn't there (google CDN blocked etc.)
// -- no jQuery is as good as no JavaScript at all for our purposes
var checkForJQuery = function (siteName) {
  if (!window.jQuery) {
     ...
     warning.innerHTML = siteName + " works best with jQuery enabled";

And somewhere in April 2011 this changed to:

if(!window.jQuery)
  ...
  c.innerHTML = a +
  " requires external JavaScript from another domain, which is blocked or failed to load.";

Note that the above will not work if Stack Exchange's own sstatic.net CDN is blocked, as then the above JavaScript is not even loaded. Except on Meta, where the static resources are not loaded from that domain. So, here on Meta one might get the warning, while on the other sites things fail silently if sstatic.net is blocked.

So, for future searches:

Stack Overflow works best with jQuery enabled
Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load.

share|improve this answer
    
And, some say that Internet Explorer's "InPrivate Filtering" (others blame "Tracking Protection"; might be the same thing) might block Google's CDN, when it notices that its domain is used by many web-pages, and hence figures it must be an ad. –  Arjan Mar 28 '11 at 6:38
    
And for some an old version of AdBlock blocked the loading of jQuery. –  Arjan Mar 28 '11 at 9:20
    
My Firewall was blocking the js file.That was the problem...Thanks a lot ya... –  biju Mar 29 '11 at 9:52
    
@biju: It'd be great if you posted that as an answer. –  Al E. Mar 30 '11 at 17:20

In my Firewall i had a rule to block the extension .js.I removed .js from the banned extensions list and added

ajax.googleapis.com

to the exceptions list in blocked sites.Now everything is working fine.Thanks everyone especially Arjan.

share|improve this answer
1  
Others might also need sstatic.net (Stack Exchange's static resources) to be added to such list, to allow for fetching the site's own JavaScript. But, when that is blocked, no "works best with" message would be shown either as it's that script that shows the very message. –  Arjan Mar 31 '11 at 6:46
    
already got the unblocked –  biju Mar 31 '11 at 6:48
    
I knew you did, as you did get that message :-) (As an aside: see How do comment @replies work?) –  Arjan Mar 31 '11 at 6:50
    
@Arjan :) ya got it...;) –  biju Mar 31 '11 at 7:00

I don't see this in Firefox 3.6 (latest) on stackoverflow.com either.

I suspect you either have non-default settings, or a rogue plugin. Try starting Firefox in safe mode and see if it persists.

share|improve this answer
    
yes.I better check for some plugins or addons –  biju Dec 12 '10 at 3:20
1  
oops i had webdeveloper toolbar installed and eventhough javascript was enabled,i have disable java checked.I think thats the problem.let me see if it occurs again –  biju Dec 12 '10 at 3:22
    
It still remains even after i remove the disable java check.Noe i will try unchecking strict warnings –  biju Dec 12 '10 at 10:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .