Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

When I edit my own comments, all is good. But when I as a moderator edit someone else's comment, the comment is deleted. (Using my powers to edit my own comment outside the five-minute window does not cause a problem.)

I only noticed this today, although Pat Ludwig said in chat that he thought it had happened to him a couple of days ago. Looks like the revision hasn't changed since the 24th, so that would make sense.

EDIT: Still a problem in rev 2011.1.2.1.

share|improve this question
    
Comment that any moderator can test it out on. I like turtles! – mmyers Dec 27 '10 at 16:34
1  
Another comment for testing. Turtles all the way down. – mmyers Dec 27 '10 at 16:36
    
Well, that other one didn't last long – random Dec 27 '10 at 16:37
11  
Somebody's going to need to make me an MSO mod so I can test this. For science – Michael Mrozek Dec 27 '10 at 16:38
    
Looks like all the previous test comments died. [Do they still? (No, they no longer do) -random] – mmyers Dec 27 '10 at 16:38
1  
Checked my email, it happened to me on the 24th. At the time I assumed it was my fault and didn't take the time to investigate further. (Was a tad busy :)) – Pat Ludwig Dec 27 '10 at 16:42
4  
@Pat Always assume the user is at fault. Then blame SOIS. If all else fails, frame other mods – Michael Mrozek Dec 27 '10 at 16:44
    
@Michael - Thanks, lets get that tip added to the moderator's manual! – Pat Ludwig Dec 27 '10 at 17:04
    
Happened to me once as well, a few days ago, I've been too afraid to edit comments ever since :( – Oak Dec 27 '10 at 18:16
    
@Michael: You monster? – Powerlord Dec 28 '10 at 14:51
    
@RBemrose: No YouTube here. What is it? – mmyers Dec 28 '10 at 15:26
    
YouTube was to some Portal 2 game trailer. – random Dec 30 '10 at 5:16
    
@michaelmyers - delete test -- OK – Pat Ludwig Dec 30 '10 at 5:50
    
Test comment!!! OK – Michael Mrozek Jan 3 '11 at 16:37
    
@Oak - no need to worry any more... Edit by Ivo – Marc Gravell Jan 6 '11 at 14:11
up vote 7 down vote accepted
+100

This was my bug; I fixed it a few days ago. I'll see if I can resurrect those comments...

(they will be resurrected in the next build/deploy cycle)

share|improve this answer
2  
This should probably be changed from status-norepo to status-completed then, yes? – Powerlord Jan 6 '11 at 14:48
1  
the wheel of blame is a harsh, harsh mistress – Jeff Atwood Jan 7 '11 at 5:40

I saw this a few days ago as well, but I suspect it might be a temporary bug in the mod dashboard which allows inline editing.

I can't reproduce it now, either by editing the comments above or by editing a flagged comment in the mod dashboard.

share|improve this answer
1  
You guys screwed up! ha ha - (remove tongue from cheek now) – bobobobo Jan 6 '11 at 6:28
    
It happened to me while editing from the regular question view, not from the dashboard. Was a week or two ago, though. – Oak Jan 6 '11 at 7:05
    
@Oak ha ha ! – bobobobo Jan 6 '11 at 13:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .