The mail notifications don't appear to have an option for plain-text rather than HTML, and they currently send only html parts (and hence hit the MIME_HTML_ONLY rule in spamassassin's default settings).

Also, they flag the MIME_QP_LONG_LINE spamassassin rule due to having lines longer than 76 characters.

share|improve this question
    
good to know... –  Jeff Atwood Jul 20 '09 at 11:07
1  
See also - meta.stackoverflow.com/questions/9711/… (completing the circle) –  ChrisF Jul 26 '09 at 12:55
add comment

3 Answers

up vote 2 down vote accepted

I think I see the MIME_QP_LONG_LINE but I'm not sure how to get rid of it.

edit: bug in the .NET framework! Doh!

http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=156052

Basically, long URLs occurring anywhere in the text do not contain spaces and are not broken by the Quoted-Printable MIME algorithm.

I'm going to try switching to Base64 encoding for that portion of the email.

Update: we have switched to a third party email component recommended by our pals at Doctype.

X-Mailer: MailBee.NET 5.7.2.156
From: "Stack Overflow" 

I can confirm that it "fixes" the quoted-printable encoding bug in the .NET framework.

share|improve this answer
    
Comment attempt #3 :) ietf.org/rfc/rfc1521.txt and look for the "Rule #5 (Soft Line Breaks)" section. –  Legooolas Aug 3 '09 at 9:34
    
The soft line breaks should work OK with links too, but might rely on mail clients doing things properly and hence be less likely to work in practice. (Base64 is probably a better choice because of this) –  Legooolas Aug 3 '09 at 9:35
    
The most recent changes have fixed this, cheers! :) –  Legooolas Aug 12 '09 at 11:19
    
excellent, thanks for your help on this! –  Jeff Atwood Aug 12 '09 at 22:49
add comment

For me, SpamAssassin still triggers on MIME_QP_LONG_LINE:

X-Spam-Level: ****
X-Spam-Checker-Version: SpamAssassin 3.2.5 (2008-06-10) on <hostname>
X-Spam-Status: No, score=4.9 required=5.0 tests=BAYES_99,HTML_MESSAGE,
        MIME_QP_LONG_LINE,RDNS_NONE autolearn=no version=3.2.5

But because the MIME_HTML_ONLY BODY test isn't triggered anymore, the message is not considered spam.

share|improve this answer
    
Still hits the MIME_QP_LONG_LINE one for me too. –  Legooolas Jul 31 '09 at 10:02
    
see my response, the LONG_LINE should now be fixed. Bug in .NET sadly. :( –  Jeff Atwood Nov 5 '09 at 9:46
add comment

We made some changes to address these two issues -- can you let us know if it's still an issue after tomorrow?

OK, we switched to Base64 encoding for the HTML part of the message, does this fix it?

We're also verifying our Reverse DNS (RDNS) settings, I could have sworn we had that set up correctly.

share|improve this answer
    
Still hitting MIME_QP_LONG_LINE for me, I'm afraid. –  Legooolas Jul 31 '09 at 10:03
1  
even with Base64 encoding? :) –  Jeff Atwood Aug 11 '09 at 5:37
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .