What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

It appears that the new suggested edits feature was only partially implemented with tag wikis. I experienced this problem on SuperUser, but suspect it's a system-wide issue with the engine, so am bringing it up on MSO.

  • I was given the option to edit the tag wikis for tags which already had one, but upon submitting a proposed edit, was greeted with an error screen every time.

  • Tags which do not yet have a tag wiki have no means by which to propose a new one entirely.

I'm not sure to what extent this is expected behavior and to what extent this is a bug, but it's certainly not behaving consistently.

share|improve this question
    
I have not unlocked it for "creating new wikis" will dig through and see why suggesting an edit is playing up –  waffles Jan 31 '11 at 4:03
    
@waffles, I tried again on another tag (it was google-chrome before, this time microsoft-excel) and this time it didn't show an error, but nor did it show any indication that any sort of change had been made or even suggested - everything looked exactly the same. Can you look at the tag wiki for microsoft-excel on SU and see if there's a pending edit or if it never went through even? –  nhinkle Jan 31 '11 at 4:05
    
yes the indication you made a change on tag wikis is broken, I can confirm that –  waffles Jan 31 '11 at 4:09
    
aha this is the second weird one I have seen, superuser.com/edit-suggestions/28 clearly this is not your intended edit? –  waffles Jan 31 '11 at 4:29
    
@waffles, no it is not. It looks like the original text shown is from the "excerpt" and the edited text is from the original text in the description. Neither is my actual proposed edit. –  nhinkle Jan 31 '11 at 4:38
    
Furthermore, I am being shown buttons for "reject" and "accept" edit, even though it was my own edit, which I doubt is by design. –  nhinkle Jan 31 '11 at 4:40
    
More info: I just received a notification that I had received the tag editor badge for "excel", and yet my actual edit was not shown, at least not in its entirety. –  nhinkle Jan 31 '11 at 5:51
    
@nhinkle ... I just deployed the fix ... can you try submitting a few more wiki edits (keep in mind, creating new wikis is still blocked out) –  waffles Jan 31 '11 at 6:08
    
@waffles, I submitted my suggested edits for google-chrome and microsoft-excel. It looks to me like the suggestions went through successfully. –  nhinkle Jan 31 '11 at 6:22
    
@nhinkle ... yes, looks fine to me superuser.com/edit-suggestions/31 –  waffles Jan 31 '11 at 6:25
    
@waffles, one more little issue: on the page you just linked, it said you approved the edit, but on the page itself, it still says "This edit will only be visible to you until it is peer reviewed". –  nhinkle Jan 31 '11 at 6:26
    
@waffles And upon further checking, the edits do not appear when not signed in. So even though it says on the status page that it was approved, it looks like it wasn't. –  nhinkle Jan 31 '11 at 6:27
    
aha ... I know what it is @nhinkle .... I just approved half of your edit, wikis are made out of 2 posts ... when the second part is approved the message will go away –  waffles Jan 31 '11 at 6:28
    
Ah, OK. Let me know when that's done and I'll check that everything looks right. Thanks again @waffles. –  nhinkle Jan 31 '11 at 6:30
add comment

1 Answer

up vote 3 down vote accepted

There were some serious bugs there, however I think I sorted them out now. Will be deployed shortly

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .