What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

I'm having trouble getting all of the features to work on stackoverflow.com. When I visit the site it displays a banner which says, "Stack Overflow works best with JavaScript enabled." However I have javascript enabled and other websites seem to work fine. I am running Mac OS X 10.6.6 and I've tested with Chrome, Firefox, and Safari. I get the error in all three browsers.

I have reinstalled Adobe Flash Player and Chrome in an attempt to see if that would help. It didn't seem to solve anything tho :/

Has anyone else experienced this issue?

share|improve this question

migrated from stackoverflow.com Mar 3 '11 at 17:39

This question came from our site for professional and enthusiast programmers.

    
This happened to me, tonight. I think, in my case, it was due to other services running and taking bandwidth, though. But +1 for the repro. –  David Thomas Mar 9 '11 at 1:43

4 Answers 4

For some time, that warning also popped up when jQuery wasn't available. (On March 3rd, that was a recent change, before that it would just fail silently.) Since about March 28, it specifically warns:

Stack Overflow works best with jQuery enabled

Do you have googleapis.com blocked?

share|improve this answer
    
Given buti-oxa's answer and the availability of IE9: any chance the jQuery error message could be made more specific? (See also Can't ask a question when IE Tracking Protection is enabled.) –  Arjan Mar 24 '11 at 15:56
    
And for some an old version of AdBlock blocked the loading of jQuery (probably blocked access to Google's CDN) in Firefox 4. I really think making the message a bit more specific might help! Or, SHAME ON YOU GUYS: the sites just work TOO WELL without jQuery, leaving folks wondering what is causing the message while all seems to work just fine. ;-) –  Arjan Mar 28 '11 at 9:24
7  
@Arjan: I've changed the message to say "jQuery" instead of "JavaScript". I've resisted the temptation to change the message to "-1 not enough jQuery" :) –  balpha Mar 28 '11 at 10:32
    
I wonder if a similar check should be added to the HTML itself (or hosted from /content/js/), for SE's own script? For a browser, googleapis.com and sstatic.net are both third party domains, but if the latter is blocked, the warning function won't even run of course. (I'm really scared of IE9's blocking mechanism, if that is really silently blocking things which it erroneously thinks are ads. I cannot test IE9 though; maybe it's not that bad at all.) –  Arjan Mar 31 '11 at 6:58
    
(Ah, @balpha, my last comment is also an old feature request, though not very well worded I guess: Notify to enable JavaScript on sstatic.net.) –  Arjan Mar 31 '11 at 16:21
1  
Just stalking you a bit: if you could come up with detecting if sstatic.net is blocked, then some will be happy ;-) –  Arjan Apr 25 '11 at 20:23

Another possible reason: IE with InPrivate Filtering enabled. Once it notices that jQuery is linked from Google by many web-pages you use, it decides it's an ad and blocks it.

share|improve this answer
    
Good old IE fannying everything up again –  Tom Mar 30 '11 at 16:19
2  
At least they got one thing right in IE! –  Gabe Mar 30 '11 at 16:44
    
@Gabe, how is the behavior described in the above answer the right thing to do? One day a site works just fine, the next day IE decides to block something? –  Arjan Mar 30 '11 at 18:43

Is some sort of a firewall blocking .js URLs on your infrastructure?

See if you can open the below URL in a browser.

http://sstatic.net/js/master.min.js?v=3850e24bc920

share|improve this answer
    
Is it supposed to be a whole bunch of code? Because that is what I see. –  yarian Jun 27 '11 at 19:24
    
@YGomez: Yes, it was the minified JavaScript code as of March 3rd 2011. –  adarshr Jun 27 '11 at 22:24

You must log in to answer this question.