What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

I had a simple to diagnose case today, with it being the first day of the week and me hitting the rep cap very early. Before going to sleep, my rep report was showing 3 posts marked as the answer and a bunch of upvotes that exceeded the rep cap. Reported score on the /users page (week view) was 230, 15 too few.

After a fitful sleep, 10 hours later the score was still 230, a handful of additional upvotes added that didn't count. Far too long to explain the problem away with caching I'd think. About an hour later, another post was marked as the answer. The /users score incremented to 245, still 15 too few. Looks like the rep for one of the 3 answer marks got permanently lost.

Something to help with debugging this: the three marked answers were one, two, three. The late 4th mark that incremented the score to 245 is this one. I'm not aware of anything special with these posts. The /reputation report looks like this:

 2   5207104 (10)
 1   5207104 (15)
 2   5202207 (10)
 2   5206571 (10)
 2   5208433 (10)
 2   5206797 (10)
 2   5208433 (10)
 2   5208433 (10)
 1   5208433 (15)
 2   5208433 (10)
 2   5207512 (10)
 1   5202207 (15)
 2   5208433 (10)
 2   5206571 (10)
 2   5205773 (10)
 2   5204859 (10)
 2   5208879 (10)
 2   5208879 (10)
 2   5208879 (10)
 2   5208879 (10)
 2   5207964 (10)
 2   5209032 (10)
 2   5209032 (10)
 2   5207330 [0]
 2   5208596 [0]
 2   5209032 [0]
 2   5206571 [0]
 2   5208433 [0]
 2   5197010 [0]
 2   4642034 [0]
 2   5182256 [0]
 2   4940225 [0]
 2   5208433 [0]
 2   5208596 [0]
 1   5207330 [15]
 2    297061 [0]
 2   1702625 [0]

Good luck!

share|improve this question
    
This is likely caused since our reset did not happen on the microsecond the day started. Will discuss with Nick to see if there is a way we can improve this. –  waffles Mar 7 '11 at 0:48
    
@waffles - the stackexchange league is missing one as well. –  Uphill Luge Mar 7 '11 at 0:55
    
another idea I had, if you run a recalc does this issue go away, it could be that deletion somewhere skewed the amount of rep you got. –  waffles Mar 7 '11 at 1:10
    
@waffles - yes, that worked. Not sure how deletion could explain 15 points though. –  Uphill Luge Mar 7 '11 at 1:16

1 Answer 1

This could happen under 2 conditions:

  1. A huge edge case where you gain rep in the first second of the day we reset the counters
  2. Reputation in the report represents your "real" reputation, the one on your profile is your "display reputation" these may go out of sync:
    • If people undo votes after you hit the rep cap, stuff may go out of sync
    • If questions or answers are deleted/migrated, stuff may go out of sync

To fix either you can run a recalc on the /reputation route.

share|improve this answer
    
I can't see the timestamp on the 1st answer mark to judge the humongous edge case. Completely dropping the rep for an answer mark just doesn't happen, unless there's a new failure mode. The reason I posted. But yes, I reckon it is looking for a needle in a haystack. Hope you find it some day. –  Uphill Luge Mar 7 '11 at 7:40
    
Sigh, just discovered: can ask for a recalc only once a day. –  Uphill Luge Mar 7 '11 at 22:25
    
@Hans ... yeah ... that is by design, we may allow it a bit more aggressively once we optimise the algorithm a bit –  waffles Mar 7 '11 at 22:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .