What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 122 Stack Exchange communities.

Hello..
Today i posted a question in stackoverflow here is the link

I uploaded a image from my desktop and from a comment of a user it seems that he is able to view that image but I was not able to see that link in my preview of question neither in actual question. Here is screenshot of what i see. click

again while pasting the screenshot I am not able to see it in preview.

share|improve this question
3  
I'm noticing that you have a giant whitespace where the top-banner ad should go. Perhaps, do you have some sort of image blocking service that might be affecting the site imgur.com? –  Grace Note Mar 15 '11 at 12:10
    
are you able to see the image of a shelf that i have uploaded in stackoverflow?? I am not able to see it myself at all.. –  Harshad Mar 15 '11 at 12:14
    
yes there is blocking system. I am not able to access imgur.com –  Harshad Mar 15 '11 at 12:16
    
Same problem here... imgur is blocked by our websense :-s –  fretje Mar 15 '11 at 12:19
    
This might help you and @fretje then: meta.gis.stackexchange.com/questions/249/… –  Shadow Wizard Mar 15 '11 at 13:15
    
Another option is to upload the image to any other image hosting website yourself then instead of Browsing to the image, post its URL. –  Shadow Wizard Mar 15 '11 at 13:17
    
Objection to not using the future proof SE provided image hosting, @Shadow and all! –  Arjan Mar 15 '11 at 13:55
2  
@Arjan problem is that many work places block imgur - so while future proof it's not workplace proof. :/ –  Shadow Wizard Mar 15 '11 at 14:04
add comment

2 Answers

up vote 6 down vote accepted

If you are blocking imgur - as indicated by your comment - then you will not be able to see the images uploaded as they are hosted by imgur.

If you are in control of the system then consider unblocking it.

If you aren't then you will have to make a very good case to your IT department on why it should be unblocked.

share|improve this answer
    
ok.. but then why i was not able to see that in preview as a hyperlink as i was able to see the hyperlink for "here is the link" in my question. Is it the same reason for that? –  Harshad Mar 15 '11 at 12:24
1  
@Harshad - I'm not sure I understand what you are getting at here, but the image is only displayed in the preview once it's been uploaded to imgur, so if you are blocking imgur it won't be shown. –  ChrisF Mar 15 '11 at 12:26
    
i got that ill not be able to see the image preview simply because the image did not got fetched from imgur.com. that is fine now.. what I am asking now is when it ask you to enter image description and you type something then that should appear in preview as you type right?? but it isn't. –  Harshad Mar 15 '11 at 12:35
1  
@Harshad, in the question you entered "click" as the description (which is not a very good one). This is used for the alt text. Some browsers do indeed show that if loading the image fails. Some don't, some show a broken image icon. Maybe in your case the actual image is replaced by a white image, so the browser doesn't know it's not getting the real image? –  Arjan Mar 15 '11 at 12:44
    
As you said i wrote click as description I was not able to see that description anywhere in my post as you are able to see it.Perhaps Its better i go home and check how it actually works when there is no restriction or blocking of sites. :P –  Harshad Mar 15 '11 at 12:49
1  
I do not see it either, @Harshad, unless I edit your question, or unless I view the HTML source of this very page. (Of course, I do see the image instead.) Browsers do NOT normally show it. Whether or not it's shown when an image cannot be loaded, depends on the browser. (Note that the same alt text is used for screen readers, as used by visually impaired. Those users won't be helped by "click"!) –  Arjan Mar 15 '11 at 12:54
add comment

Here is a userscript which changes all the imgur links to filmot links (an imgur mirror). Thanks to @Shadow Wizard to point me to this thing. It only worked on reddit though and only processed anchors, no image tags. I've updated it to also include this, and now I can see images again on stackexchange sites!

I also put it on userscripts.org for an easy install.

// ==UserScript==
// @name          imgur filmot
// @namespace     reddit, SOIS
// @description   Changes imgur.com links to filmot.com
// @include       http://reddit.com/*
// @include       http://www.reddit.com/*
// @include       http://stackoverflow.com/*
// @include       http://meta.stackoverflow.com/*
// @include       http://superuser.com/*
// @include       http://meta.superuser.com/*
// @include       http://serverfault.com/*
// @include       http://meta.serverfault.com/*
// @include       http://askubuntu.com/*
// @include       http://meta.askubuntu.com/*
// @include       http://answers.onstartups.com/*
// @include       http://meta.answers.onstartups.com/*
// @include       http://nothingtoinstall.com/*
// @include       http://meta.nothingtoinstall.com/*
// @include       http://seasonedadvice.com/*
// @include       http://meta.seasonedadvice.com/*
// @include       http://crossvalidated.com/*
// @include       http://meta.crossvalidated.com/*
// @include       http://askdifferent.com/*
// @include       http://meta.askdifferent.com/*
// @include       http://stackapps.com/*
// @include       http://*.stackexchange.com/*
// @exclude       http://chat.stackexchange.com/*
// @exclude       http://api.*.stackexchange.com/*
// @exclude       http://data.stackexchange.com/*
// @exclude       http://area51.stackexchange.com/*
// @exclude       http://*/reputation
// ==/UserScript==

var anchors = document.getElementsByTagName('a');
for (var i = 0; i < anchors.length; ++i) {
    var a = anchors[i];
    if (a.href && a.href.indexOf('http://imgur.com/') == 0) {
        a.href = a.href.replace('http://imgur.com/', 'http://filmot.com/');
    }
    if (a.href && a.href.indexOf('http://i.stack.imgur.com/') == 0) {
        a.href = a.href.replace('http://i.stack.imgur.com/', 'http://i.filmot.com/');
    }
}
var imgs = document.getElementsByTagName('img');
for (var i = 0; i < imgs.length; ++i) {
    var img = imgs[i];
    if (img.src && img.src.indexOf('http://imgur.com/') == 0) {
        img.src = img.src.replace('http://imgur.com/', 'http://filmot.com/');
    }
    if (img.src && img.src.indexOf('http://i.stack.imgur.com/') == 0) {
        img.src = img.src.replace('http://i.stack.imgur.com/', 'http://i.filmot.com/');
    }
}
share|improve this answer
    
Cheers, glad to lend a hand! And @Arjan - guess this is ideal solution, as images will still be hosted on the future proof host. –  Shadow Wizard Mar 15 '11 at 14:06
    
Nice! Alternatively, as a quick & dirty bookmarklet when knowing jQuery has been loaded (like on the Stack Exchange sites): javascript:function r(i,v){return v===undefined?v:v.replace(/(\w*\.?)imgur\.com/i,'$1filmot.com');}$('a').attr('hr‌​ef',r);$('img').attr('src',r); –  Arjan Mar 15 '11 at 18:24
    
It seems there's also an official imgur.com alternative domain, imgur.voxcdn.com. But that uses the very same IP addresses so is probably blocked too. (@Sha) –  Arjan Mar 19 '11 at 12:14
    
Since May 2011, images uploaded to the SE pro account use the stack.imgur.com domain (and hence i.stack.imgur.com and maybe even more). The filmot.com proxy does not support that. See also Any details about stack.imgur.com? –  Arjan May 8 '11 at 10:21
    
Yeah, this doesn't work anymore. :( –  John Aug 3 '11 at 2:53
    
This might still work using i.stack.imgur.com.prx2.unblocksit.es, like here, but that would first need a cookie by clicking "Unblock" on unblocksit.es/unblock/imgur.com –  Arjan Nov 27 '13 at 20:08
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .