Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I seem not to be able to flag anything on this computer. Whenever I click flag, I receive the little orange box saying “Unable to load popup - please try again (click on this box to dismiss)”.

I use Firefox with NoScript (with exceptions for SO, of course), but I tried to deactivate NoScript, no change. Firefox error console shows no error. I have even tried IE with the same result (which puzzles me the most). I was able to flag at home (on a different computer).

share|improve this question
Versions of IE and Firefox? And have you tried with Chrome? And is this a new problem for you? – Benjol Mar 15 '11 at 14:31
@Benjol - Firefox 3.6.15, IE 8 (x64, if that’s important…); it is not new, I am not sure whether I was ever able to flag anything on this computer or not; I remember the box has appeared before, I just thought it was a temporary glitch. – Mormegil Mar 15 '11 at 14:48
up vote 7 down vote accepted

I have resolved the problem: By debugging the JavaScript, I noticed there is a failed AJAX request for something like “/posts/popup/flag/123456?=987654”. I tried to access the page directly with the browser and received an empty page. So I tried using wget and received “HTTP/1.0 404 Dropped by firewall”.

So, obviously, our brain-damaged firewall is to blame here (I guess the “popup” part of the URL matched some ill-advised rule), no fault on SO side.

share|improve this answer
I have the same problem, for the same reason. – Ray Apr 12 '11 at 8:01
thanks for the update, hopefully this will help others! – Jeff Atwood Aug 6 '11 at 4:10

Knowing nothing about javascript but nevertheless trying to debug it with Chrome I seem to find that in my case the culprit is Privoxy.

share|improve this answer
Confirmed. I see "Crunch: Blocked" in my privoxy log. Seems to block it because it has "popup" in the path. – Burhan Ali Nov 18 '11 at 15:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .