What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

Browser Firefox 3.6.13

Login in Skeptics-chat fails, but not to Stackechange-chat. The diagnostic page at …

http://chat.stackexchange.com/help

… reveals something about my referrer:

IFRAMEs – ok
Referrer – failed

Your browser is not sending a recognized site in its HTTP referrer header.
We received "".

about:config shows:

network.http.sendSecureXSiteReferrer standard boolean true

Ghetto-login works.

Logout/login doesn't work. I'm helpless.

share|improve this question
    
It's a conspiracy. Don't let them know you know. Don't let them know you are letting them know you know. Pretend not to know. Inform others, in secret. Good luck. –  Tom Mar 24 '11 at 11:31
add comment

2 Answers

up vote 3 down vote accepted

The applicable Firefox about:config setting is

network.http.sendRefererHeader

and has to be set to 2 for chat.SE login (or global login in general) to work.

share|improve this answer
    
So is firefox wrong, calling that thing 'Referer' with single 'r'? Maybe the helpscreen could include a hint 'firefox -> about:config -> network.http.sendRefererHeader value 2'? At least it works now, after I changed it from 1 to 2. Do you have a brief sentence, what the values do? –  user unknown Mar 24 '11 at 9:24
1  
@userunknown: a) the "Referer" thing is a long story -- simply put, a typo that made it into the standard (see Wikipedia). b) If you (or some of your extensions) change your Refer(r)er settings, you have to accept that this may break the internet. We're not going to write up "What special settings to undo for it to work" how-tos for every browser and every setting you could possibly change. 3) AFAIK "2" always sends the refer(r)er, "1" sends it only when you clicked a link, "0" never sends it. –  balpha Mar 24 '11 at 9:44
add comment

Looks like your browser is misconfigured or has rogue extensions.

Try running Firefox in safe mode, that is, disable all extensions. Does that change the results?

Try using Google Chrome as well, to compare results.

share|improve this answer
    
Thanks for the advice, but balpas hint is much faster testable, and it worked. :) –  user unknown Mar 24 '11 at 9:26
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .