What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 130 Stack Exchange communities.

I'm getting a red bar on top of each page which says "Stack Overflow works best with JavaScript enabled". My JavaScript is enabled. Otherwise everything is working well.

EDIT: nope, I am not using NoScript and am also not seeing jQuery effects. It's not blocked. Everything worked well in Firefox 3.6 before I updated.

EDIT 2: AdBlock was the culprit. Updating AdBlock fixes it.

EDIT 3: Nope, not Adblock. Not any of the extensions (uninstalled everything, not just disabled). It's an intermittent problem. Sometimes it will show the red bar, but refreshing the page will fix it. Other times refreshing it won't fix it at all. Usually it works. Looks like a bug.

share|improve this question
    
have you installed noscript? –  YOU Mar 28 '11 at 4:35
    
Are you seeing the effects that rely on jQuery? Like when hovering a tag, or when hovering your own username? See also Employer blocks jQuery from Google, DOH! –  Arjan Mar 28 '11 at 6:43
    
nope, didn't install noscript. when the bug acts up, i can't see any jquery effects. –  maranas Apr 19 '11 at 6:26
    
Try clearing the cache of Firefox. –  mc10 Apr 20 '11 at 5:11

3 Answers 3

up vote 7 down vote accepted

I am using Firefox 4.0 and I get no such warning; JavaScript works fine on Stack Overflow. You are likely using any addons that are disabling JavaScript, such as NoScript. Try disabling them, or creating an exception for Stack Overflow. See also this question: “Stack Overflow works best with JavaScript enabled”, but I have JavaScript enabled by default

share|improve this answer
    
Updated AdBlock Plus to 1.3.5 and it fixed the problem. –  maranas Mar 28 '11 at 9:10
1  
Actually, no. updating adblock doesn't fix the problem. It is intermittent - sometimes it will show the red bar, but refreshing the page will fix it. Other times refreshing it won't fix it at all. Usually it works. Looks like a bug. –  maranas Apr 18 '11 at 11:29

Up to the end of March, this text could have been caused by Google's CDN being blocked. Not so much anymore; the text is really coming from the following HTML:

<noscript>
  <div id="noscript-warning">
    Stack Overflow works best with JavaScript enabled 
    [...]
  </div>
</noscript>

I really think your browser or add-ons are to blame.

share|improve this answer
1  
Unless you're seeing a totally different message: Stack Overflow works best with jQuery enabled. –  Arjan Apr 18 '11 at 14:21
1  
This was what I first thought too, but now I've uninstalled (not just disabled) all my add-ons, and it still happens intermittently. Funny thing is, refreshing a page will sometimes fix the problem. –  maranas Apr 19 '11 at 6:24
    
There is no way that Stack Exchange can make your browser interpret the HTML <noscript> erroneously, @maranas. When it happens again, maybe a view source followed by a search for that <noscript> can reveal something changed the HTML source? I assume you would have noticed a bad internet connection. (And, again, just to be sure, you're REALLY not seeing a slightly different message, right?) –  Arjan Apr 19 '11 at 6:45

Most likely extension related. I'm using Firefox 4, with minimal extensions (web developer + firebug), and have experienced no problems. try disabling all extensions, and then re-enabling them one by one until you find the extension (or combination thereof) that generates the problem. If you still get the problem with absolutely no extensions installed, it is indeed an odd problem.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .