What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

This is something new. I was using an RSS reader that checked questions for some tags every minute. It was working fine till recently. But now sometimes there are questions asked 1 hour ago but I don't get the feed. Even after I see the question in webpage and request feed, it just doesn't appear. I refresh feeds with Google Reader and Feed notifier at the same time, Google Reader gets something new but Feed Notifier doesn't. Is there some kind of request restriction for RSS feeds? Maybe based on IP? Or is the problem about readers?

This request was taken a few minutes ago:

GET /feeds/tag?tagnames=asp.net-mvc&sort=newest HTTP/1.1
A-Im: feed
Accept-Encoding: gzip, deflate
Connection: close
Accept: application/atom+xml,application/rdf+xml,application/rss+xml,application/x-netcdf,application/xml;q=0.9,text/xml;q=0.2,*/*;q=0.1
User-Agent: FeedNotifier/2.2 +http://www.feednotifier.com/
Host: stackoverflow.com
If-Modified-Since: Thu, 14 Apr 2011 11:14:59 GMT
share|improve this question
    
Could you mention which RSS Reader? –  YOU Apr 12 '11 at 8:12
    
Feed Notifier and Google Reader. They are both "late" –  Ufuk Hacıoğulları Apr 12 '11 at 8:21
2  
Could this be related to Feeds don't expire when requested with gzip encoding? Any chance you can sniff into the readers request to see if it sends Accept-Encoding: gzip, deflate or something similar? –  Arjan Apr 12 '11 at 8:26
1  
So, any news on the Accept-Encoding sent by your reader? –  Arjan Apr 13 '11 at 11:06
    
The problem seems to be more complex. Gzipped and uncompressed feeds seem to be cached separately but they both don't expire on time. –  Quassnoi Apr 13 '11 at 21:45
1  
We have seen this, and I am investigating. I was under the impression (from the linked thread) that it had evaporated, but obviously not. –  Marc Gravell Apr 21 '11 at 10:15
    
@Marc Gravell: Any update on this? I'm seeing this issue as well. –  FogleBird Jun 28 '11 at 19:52
    
@FogleBird really? this just refuses to die, eh? After investigation I was under the impression that this was fixed. I'll revisit it. –  Marc Gravell Jun 28 '11 at 20:27
    
@Marc Gravell: Right now, this feed is out of date for me, for example: stackoverflow.com/feeds/tag/python –  FogleBird Jun 30 '11 at 14:36
    
@FogleBird - it is... curious; more detail: stackoverflow.com/q/6546444/23354 –  Marc Gravell Jul 1 '11 at 10:03
    
Fixed next deploy –  Marc Gravell Jul 1 '11 at 11:53
    
Isn't hitting an RSS feed once a minute rather bad RSS etiquette? I thought most consumers of RSS limited themselves to once an hour (or so) to keep from overloading the RSS provider. –  Al E. Dec 25 '11 at 14:52

2 Answers 2

up vote 2 down vote accepted

We had a bug in our output-cache provider, so it used sliding instead of absolute expiry. So it was only when the readers stopped hitting it that it would expire.

Fixed next deploy.

share|improve this answer
    
Nice work, thanks! –  FogleBird Jul 1 '11 at 15:26
    
I haven't been using RSS feed for a long time but I tried it today since you said it was fixed. I don't know if it's the reader (Feed Notifier) or some other thing but it's still there. –  Ufuk Hacıoğulları Jul 18 '11 at 11:15
    
@Narsil - which "it"...? can you be specific about symptoms? sorry if this seems redundant, but I want to be sure it is the same thing, vs something crazy similar-sounding... –  Marc Gravell Jul 18 '11 at 11:21
    
I see some question is posted from StackGuru but I don't get anything from RSS feed. –  Ufuk Hacıoğulları Jul 18 '11 at 11:28
    
@Narsil - which feed; can you give your feed url? –  Marc Gravell Jul 18 '11 at 11:38
    
stackoverflow.com/feeds/… For example this question doesn't show up in that feed –  Ufuk Hacıoğulları Jul 18 '11 at 11:50
    
@Narsil indeed it doesn't, but the feed is up to date; <updated>2011-07-18T11:51:48Z</updated> - so: if there is a bug, it is different. I will investigate, but that is not the same thing. –  Marc Gravell Jul 18 '11 at 11:53
    
@Narsil - that feed is "1st tag AND 2nd tag"; the post you cite only has 1 of the tags; you probably mean "1st tag OR 2nd tag", i.e. like this –  Marc Gravell Jul 18 '11 at 11:57
    
The problem is in the feed URL. I don't know where I got it from but it only shows questions tagged with asp.net-mvc and asp.net-mvc3 both. The question is displayed in only asp.net-mvc-3 tag feed. –  Ufuk Hacıoğulları Jul 18 '11 at 11:57
    
@Marc you are right. I will keep checking it for a while. –  Ufuk Hacıoğulları Jul 18 '11 at 12:05

The question is very old. However, I had the same problem.

I added the Recent C# questions feed to Feed Notifier and set the refresh interval to 30 seconds. I refreshed the appropriate webpage accordingly in order to see, if it works. Guess what, new posts were late in Feed Notifier! But I've looked into the feed with my browser, and it seems to me, that feed data provided by SO is updated only every 5 minutes.

share|improve this answer
    
You may want to ask a new question about this –  Ufuk Hacıoğulları Dec 25 '11 at 12:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .