What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

I think the title says it all. The individual question div's are being classed as "tagged-ignored-hidden". That style has the following definition: display:none;.

Searching on just the vb.net tag (ie, [vb.net]) or just the keywords (ie, anything) but putting the two together causes the bug. Searching on other tags seems to work. The problem also seems to happen when searching on the [.net] tag as well. Maybe it has something to do with the period (.) in the tag?

share|improve this question
1  
Do you have the vb.net and .net tags marked as ignored in your Stack Overflow profile's prefs tab? –  Grace Note Apr 25 '11 at 15:28
    
@Grace when I add that tag and do the search I still see the results, they're just grayed out like ignored tags should be - they're not display: none –  Daniel DiPaolo Apr 25 '11 at 15:29
1  
@Daniel What about if you set the "Hide My Ignored Tags" setting? Are they hidden in both views, or only in the compound search? –  Grace Note Apr 25 '11 at 15:30
    
@Grace aha, that did seem to do it - will update my answer below –  Daniel DiPaolo Apr 25 '11 at 15:33
    
@Grace Note: You win the prize. I set those to ignored a year and a half ago when I first set up my SO account and long since forgot about doing it. If you want to add those two comments as an answer I'll gladly accept it. Thanks for your help! –  mwolfe02 Apr 25 '11 at 15:40
    
Possibly related, though no exact dupe: meta.stackexchange.com/questions/156547/… –  Spontifixus Jan 7 '13 at 14:07

1 Answer 1

up vote 3 down vote accepted

This is specific to neither Chrome, nor for periods in tags. You just have a few ignored tags that are hidden for you. This was confirmed using IE8 with (that I just found on the front page).

It's simply a matter of how ignored tags work when you have "Hide My Ignored Tags" set.

If you are performing a tag search only (as in, the only search terms are [tags]), then it temporarily overrides the hiding functionality of any such tags specifically in your search. This way, if you have for example ignored, then it doesn't show you absolutely nothing when you explicitly search in the java tag. Note that if you are fiddling with your preferences on the questions page, it may require a refresh to get visibility back.

However, if you perform a normal search or a compound search (as in, there are non-[tag] search terms), then it will behave as normal for the system - it will hide all questions with that tag. Naturally, this results in nothing when you are doing a compound search with that term.

I'd suggest either removing the ignored tag (if you don't actually want to ignore it), or otherwise disabling the "hide" option. There is also an open feature request for allowing easier access to disabling the hiding functionality.

share|improve this answer
    
Are you sure about this? I have the [java] tag ignored (and ignored set to hidden), and when I do stackoverflow.com/questions/tagged/java I get > 2000 pages of no results. –  user27414 Apr 25 '11 at 21:15
    
@status I was able to see the java questions with the tag ignored and hidden in IE8, Firefox, and Chrome. It may require refreshing once, though. If not, um... bug report, I s'pose. –  Grace Note Apr 26 '11 at 11:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .