What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

Today I asked a question about which PHP install package was best for an Apache-based PHP web-development environment. This seems straight-forward enough, and I believed it to be well within the defined scope of SO from the FAQ:

"If your question (generally) covers software tools commonly used by programmers then you’re in the right place to ask your question!"

Although the question got four upvotes in five minutes, it also collected one close vote. When I asked why, a user commented that, "by using the verb install multiple times you have disqualified the question for being about the programming tool itself".

This baffled me considering the number of accepted questions on SO about installing programming related tools:

Immediately after that user's comment, however, the question was then (unhelpfully) migrated to SuperUser, a place totally unsuited to questions about preferable programming environments. It lasted a few minutes there before SU mods saw it was out of place on and moved it to ServerFault.

A place specifically for Server administration.

And there it sits: Installing PHP for development

Is it really outside of SO's scope to ask a question about which version of a programming language is best suited for using in a development environment? I'm not setting up or administering a web server as professional admin, just as a programmer.

share|improve this question
1  
Why do people try to justify bad questions (not including your question in that) by citing other bad questions? 1.5 million questions. Million. –  Won't Apr 26 '11 at 18:38
4  
Well, if the community is supporting the topic sometimes, but not at other times, then there is a disparity in understanding and agreement on scope. Citing notable questions (not "bad" questions) is useful evidence that such a thing might be occurring. You'll note that the questions I chose as examples have over 40k views, 43 upvotes and 21 favourites, in total. They have not been ignored by the community. –  Django Reinhardt Apr 26 '11 at 18:45
2  
I had a read, and it's now back on SO, where it belongs. You might want to be more careful with word order, as some people seem to stop reading when they hit 'install', and ignore that it's plainly about getting a dev environment set-up. –  Phil Lello Apr 26 '11 at 18:53

4 Answers 4

up vote 13 down vote accepted

Some over-enthusiastic users have replaced their brains with a few simple regular expressions.

Software tools questions are on-topic for SO. Installing software is on-topic for SU. Installing server software is on-topic for SF. So you could argue that this is on-topic for any of The Trilogy sites.

But it was asked on SO. Bumping it around to all three sites doesn't do anyone any good. So I've restored it on SO, and deleted it elsewhere.

share|improve this answer
    
Ah! Thanks so much. When it bounced over to SF it almost became a joke. (I was half-expecting someone to flag for migration to SO, and so start the process over again!) –  Django Reinhardt Apr 26 '11 at 18:57
1  
@Django: just to make it interesting, I migrated it back to SO, and then merged it with itself. Unfortunately, this didn't do anything terribly fun. –  Shog9 Apr 26 '11 at 19:00
    
Lol. Thanks again. –  Django Reinhardt Apr 26 '11 at 19:02
1  
This question was doomed from the start. I think half of the people that answered/commented were answer poaching and didn't even read the question. I mean, it wasn't obvious that you weren't looking for a stack, but why in the world would anyone post a free server signup link? Ugh –  Nic Apr 26 '11 at 19:08
    
I know. It's bizarre and sad. –  Django Reinhardt Apr 27 '11 at 0:38
    
@Shog9 I don't suppose you could take a look at the question that started this conversation again? stackoverflow.com/questions/5793751/… –  Django Reinhardt May 10 '13 at 15:33

It's a toss-up for your question, because you are asking about a server environment. Yes, you want to use that server for development, but you are installing the combination of Apache and PHP, and these are both generally associated more with servers than development.

If you really wanted the programming experts to weigh in, I'd reformat the question completely:

Which PHP/Apache install is most appropriate for programming and development on a windows machine?

VC9 x86 Non Thread Safe
VC9 x86 Thread Safe
VC6 x86 Non Thread Safe
VC6 x86 Thread Safe

It appears that VC9 is not appropriate for Apache, but I'd like to use the latest version of PHP. What are my options, or why should I develop for a lower version of PHP?

share|improve this answer

Stuff happens.

In cases like this, flag for moderator attention. Mods can undo a migration or close.

And, yes, your question was on topic.

share|improve this answer

Your question wasn't about "preferable programming environments". It was plainly a "how do I install" question. I don't believe those are ever on topic on SO.

But obviously there are already a ton of them. Your question specifically is covered by numerous duplicates (and in hindsight should have been closed rather than migrated):

Note how this topic also comes up in an actual programming flavour, where there's really no question about the on-topicness:


It's an interesting issue nevertheless. Where should your question go if you don't want it closed and your personal don't-like-XAMPP request answered? I doubt it was on-topic on serverfault, which is about professional server management, not how do I install inquiries.

share|improve this answer
    
Mario, it was not a "how I do install" question. It was clearly a, "which is best for my environment" question. –  Django Reinhardt Apr 26 '11 at 18:51
    
Well, I would say the best for your environment is the one that doesn't crash. One that everyone else uses is a good choice. It depends on your used (??) Apache release, and of course, Windows version (?). -- I can't find the canonical answer, but there was one, shortly after that PHP5.3.3/VC9 issue came up. -- Maybe I overlooked the actual question scope, but I'm not sure how much answer detail you expected (it doesn't affect the language runtime either way), and what the not using XAMPP was about. –  mario Apr 26 '11 at 19:02
    
Not using XAMPP was about this: stackoverflow.com/questions/5580342/… –  Django Reinhardt Apr 26 '11 at 19:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .