Original question, shortened for clarity

It's been a few days that jQuery is inactive on the Stack Overflow pages I load. First I thought it was because my network was blocking some servers hosting the JavaScript code, but today being annoyed, I opened the Firefox console and saw that jQuery has a too much recursion error.

[...]
[14:00:37,946] GET http://static.adzerk.net/Advertisers/2322.jpg [HTTP/1.0 304 Not Modified 128ms]
[14:00:38,022] too much recursion @ http://ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js:16
[...]

Oct 2011 update

The bug came back. It is VERY difficult to reproduce. I duplicated my FF profile to clean passwords & history for helping others to reproduce, but now it is gone. Really don't know what to do, any help for reproducing or getting more info to help solving this bug appreciated.

I have set up an account with my tags, it is the minimum for trying to reproduce, if others want to test: Using SE OpenID, login: chbrosso+testso@gmail.com, pwd SOTest31

SUMMARY for now

  • Makes JQuery effects inactive (user dropdown menu, window on tags mousehover, and cross on ignored tags)
  • Happens on Mac only, I use Windows at work and it never happened. Impacted versions are Firefox 4 to 7 (haven't tried beta channel)
  • Related to a high number of ignored tags. When using around 80 ignored tags, it doesn't happen
  • The JQuery effects are back when clicking on the MetaSE dropdown menu
  • Is very difficult to reproduce, haven't managed to export a Firefox profile for repro, and fresh profiles don't show the bug.
  • When reproduced, all pages that display the number of ignored tags (main page and user prefs) makes the bug happen
  • Bring up FireBug debugging and the bug doesn't happen
share|improve this question
    
Strange Indeed, your version of stub.js (5f70a9de42cc) is current one on Stack Overflow. I have no problem. Can you try with Firefox extensions disable? –  YOU May 4 '11 at 12:16
    
@YOU: This fixes the problem. I'm investigating which extension is the culprit –  CharlesB May 4 '11 at 12:58
    
Glad it's solved, please let us know what was the culprit so we can use it as reference in the future. :) –  Shadow Wizard May 4 '11 at 13:02
2  
OK it's not that simple, all plugins and extensions disabled by hand and the problem is still there... What the difference between this and "restart firefox without extensions"? –  CharlesB May 4 '11 at 13:08
    
@CharlesB, may be superuser.com users might have some clue? I know some preference will be different, but I am not sure which settings effecting you. –  YOU May 4 '11 at 17:57
    
Yikes! After switching to a fresh FF profile and going back I can't reproduce... –  CharlesB May 5 '11 at 12:24
    
I'm looking at the SO homepage in FF5 (on Windows) after copying all your ignored tags, and I'm still not seeing any issues. And if it still works when you disable your plugins, this certainly suggests the issue is in your browser. –  balpha Jul 14 '11 at 14:39
    
Yeah problem seems to be only on Mac, and not on fresh profiles. If problem is in FF I don't know what to report, though. Bug in JS engine? –  CharlesB Jul 14 '11 at 14:40
    
@CharlesB - How many ignored tags do you have? I have 130, and I've been using the account without any errors for some time now. (Copy-paste into a text editor and count spaces to make that go faster). –  Kevin Vermeer Oct 11 '11 at 13:29
    
@KevinVermeer I have 192 ignored tags; are you on Firefox Mac? –  CharlesB Oct 11 '11 at 13:35
    
Not at the moment, but I can be when I get home. –  Kevin Vermeer Oct 11 '11 at 13:44
add comment

2 Answers

up vote 2 down vote accepted

I realized that I was setting Firefox to run in 32 bit, for compatibility with PDF plugin. Last week I switched to 64 bit, and the problem disappeared, so I guess it was related: FF in 32 bit mode has issues with "large" jQuery stuff.

share|improve this answer
add comment

You probably have an older version of the script in your cache.

Press Ctrl+F5.

share|improve this answer
2  
Did cmd-maj-R (I'm on mac), but problem is still there –  CharlesB May 4 '11 at 12:11
    
If "mai" is not Shift, @Charles, then use Command-Shift-R to force reloading the cache for that page. –  Arjan May 4 '11 at 12:30
    
@Arjan: Sorry, in french maj is short for shift... –  CharlesB May 4 '11 at 12:44
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .