What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 134 Stack Exchange communities.

As you can see above chrome downloads the pages instead of displaying them (in ~1:5 ratio). This happens on Firefox too. It's not my network problem because this doesn't happen with any other sites.

EDIT: While I was adding a comment:

Looks like the site was loading some content via AJAX and this stuff is returned.

EDIT 2: My browser versions: Chrome stable, Firefox stable, Chrome beta. OS: Windows 7.

share|improve this question
1  
The most likely explanation is that your Alt key on your keyboard is stuck. –  Cody Gray May 11 '11 at 7:01
    
this doesn't happen with any other sites ? –  user552747 May 11 '11 at 7:05
3  
It also doesn't happen on anyone else's computer. Have you tried clearing your browser cache and restarting it? Also, please update your question to include more details about your browser version, operating system version, etc. –  Cody Gray May 11 '11 at 7:07
    
I guess this is caused by the excessive first two lines. The first line should be the HTTP/1.1 200 OK. So, something between your browser and the internet is adding something (the zero and the blank line) before that. (I'd say: clear all your cache, then restart your whole computer and your modem.) –  Arjan May 11 '11 at 8:25
    
@balpha, no way SE would be sending one user an excessive zero and blank line before the actual HTTP response, right? –  Arjan May 11 '11 at 8:36
    
I agree that something seems to intercept/change the content of the responses on the fly. Could you please provide detailed information about your system and network configuration (including AntiVirus, AntiMalware, Spam-Filters and router/modem)? –  Time Traveling Bobby May 11 '11 at 8:40
1  
Also, since this seems to be a generic issue, maybe we should migrate this to SU? (Yes, I know that questions about websites are off-topic, but this is in my opinion a question about a network/browser issue.) –  Time Traveling Bobby May 11 '11 at 8:43
    
In it's current form there's not enough information to go on in Super User either, I'd say, @Bobby. (But I agree this is off topic here.) –  Arjan May 11 '11 at 9:42

2 Answers 2

Definitely local problem with your machine and/or browser otherwise others would have reported it as well by now..

Take a look here:
http://www.google.com/support/forum/p/Chrome/thread?tid=4acaa10690fb792a&hl=en

Also might be a virus or program you installed that open gzip so the browsers think they should download it.

Edit: the last answer in the above thread might be your case as well:

Just disabled Avast Web Shield, no more .gz downloads!

share|improve this answer
    
I don't have avast installed . If it was a virus then all sites that use gzip compression would have been downloaded , right ? –  user552747 May 11 '11 at 7:23
    
Have you installed any fancy program recently then? Or has this been always like this for you? –  Shadow Wizard May 11 '11 at 7:46
    
No fancy/new programs . –  user552747 May 11 '11 at 7:55
    
Sorry, as stumped as you are.. did you try with IE? :/ –  Shadow Wizard May 11 '11 at 8:00
    
(If this were related to some external —non add-on— program that registered itself for some specific content type or content encoding, then one would not see the HTTP headers. The browser would only send the content, not the headers, to that registered program.) –  Arjan May 11 '11 at 8:38
    
@Arjan good point, but any idea what it might be then? –  Shadow Wizard May 11 '11 at 8:45
    
Like I commented above, I assume the behavior is caused by the erroneous zero and extra newline. I've no idea what inserts those excessive characters before the HTTP response though; could even be the ISP for all we can tell. But I cannot imagine this is related to SE. –  Arjan May 11 '11 at 9:33
    
@Arjan I still suspect some browser plugin, might be installed by "innocent" program as well. –  Shadow Wizard May 11 '11 at 10:21

Try a different web browser, one other than what you normally use. Can you reproduce it then?

Try disabling any anti-virus or firewall software.

If you are behind a proxy or corporate firewall, try from home.

share|improve this answer
    
I tried it in 3 browsers but the problem is not solved . I don't have any firewall or AV installed and am not behind any proxy . –  user552747 May 11 '11 at 7:32
1  
@user, your internet provider might still be proxying. –  Arjan May 11 '11 at 8:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .