your communities

There's yet another minor bug in the reporting of tag wiki edits in the user activity tag: there's no title or link to the edited object.

no tag name or link on a wiki activity log

share|improve this question
add comment

1 Answer

up vote 4 down vote accepted

I added a bunch of new post type ids to the Posts table yesterday:

4  |  Tag Wiki Excerpt
5  |  Tag Wiki 
6  |  Moderator Nomination
7  |  Wiki Placeholder, for FAQ section on SE sites etc... 
8  |  Privilege Wiki, editable on meta  

Previously they all shared the same post id (3), which cause lots of confusion. The new change makes a lot of code clearer.

Unfortunately, this led to this regression, yet again.

Fixed now

share|improve this answer
    
to be deployed today –  waffles Jun 1 '11 at 0:45
    
Ack... so PostTypeId = 3 will not exist now? This will break SEDE queries. Could you remap so that tag wikis are 3, then excerpt = 4, nomination = 5, etc.? –  Jon Seigel Jun 1 '11 at 2:25
    
@Jon ... all the past is already remapped now , next data dump will pick it up –  waffles Jun 1 '11 at 2:28
    
Yeah, what I'm wondering is why the value 3 was not reused for Tag Wikis? –  Jon Seigel Jun 1 '11 at 2:30
    
@Jon cause there are 2 types of tag wikis, now I know that 3 means orphan wiki and stuff that we failed to map. it helps me find errors –  waffles Jun 1 '11 at 2:31
    
Ah okay, fair enough. Thanks for the explanation. –  Jon Seigel Jun 1 '11 at 2:32
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .