What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 133 Stack Exchange communities.

Sorry, I didn't know where else to post this, but is there something going on with Stack Exchange's servers lately? The Stack Exchange sites have been pretty poor performers for the past couple weeks.

EDIT: More details: basically even just going to stackoverflow.com makes my browser sit there, loading & loading. Sometimes hitting ESC to stop loading and going to the URL again will work. There are also random stalls (as users noted below) while upvoting comments, etc. I'm in a major metropolitan city with a fast connection, and all other sites are blazing fast.

share|improve this question
1  
Anecdotally, I have noticed that the response to certain actions (e.g. closing a question) has been getting randomly stalled, but I can't point to anything specific. –  Robert Harvey Jun 6 '11 at 15:16
    
Specifying your location might help. Could be the recent switch to a CDN. –  Loïc Wolff Jun 6 '11 at 15:19
4  
"Sorry, I didn't know where else to post this" -- this is exactly the right place to post this. However, a few more details would be helpful. –  balpha Jun 6 '11 at 15:23
    
@balpha Details added. –  CaptSaltyJack Jun 6 '11 at 19:14
    
According to Chrome inspector, the trouble lies with accessing files on cdn.sstatic.net, which took a whopping 6 seconds!! And these are just small files, 15k, 50k, etc. –  CaptSaltyJack Jun 9 '11 at 18:40

You must log in to answer this question.

Browse other questions tagged .