What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 127 Stack Exchange communities.

I added a comment that contains several italicized words, and some links with URLs that contain comments as well. The underscores are well-paired, however after the first URL (which contains two underscores), underscores start appearing.

I think this may be related to some other bugs related to italics in markup. This one: Italics markup not working in comments has a problem with asterisks and double quotes, and this one: Markdown italics with underscores look good in preview but not in answer pertains to answers, not comments.

The post in question: What is the word or phrase of the relationship between an account and a bank?

The text of the comment:

I hate to complain, but _owned by_ does not work, as the bank does not own the account.  _Maintained_ seems to refer to an account value. _Rendered_ implies that ownership is transferred. _Controlled_ is performed by the account holder. I could not find [usage examples of account is _administered_, _implemented_, or _trusteed_](http://ngrams.googlelabs.com/graph?content=account+is+implemented%2Caccount+is+administered&year_start=1800&year_end=2008&corpus=0&smoothing=3).  _Handled_, _Operated_ and _run_ refer to way the account is used. On the other hand, _kept_ seems to work OK.
share|improve this question
    
Hmmm. I wasn't aware underscores were even used for italics. –  Anthony Pegram Jun 16 '11 at 18:59
    
@Anthony It's just an alternative to asterisks. No mechanical difference otherwise. –  Grace Note Jun 16 '11 at 19:00
add comment

2 Answers

up vote 4 down vote accepted

This is because of the same problem as highlighted before - you followed the formatting characters with an illegal character. In this case, it's a right bracket in your URL syntax. It breaks at the following snippet:

or _trusteed_]

which causes it to be italicized up to the next valid terminating mark. Which is at the end of the following snippet.

).  _Handled_,

Italics and bold, whether you use underscores or asterisks, only work if they are followed by a whitespace, or a very small subset of terminating punctuation. Which is mostly just period and comma. Maybe semicolon and exclamation, I don't really use them at the end like that.

Point is, square bracket is to blame. Consider putting the terminating punctuation inside the link, that'd fix it. It will make the punctuation part of the link, yes, but then it won't break your formatting.

share|improve this answer
    
thanks, I moved the period to inside the bracket to look this this: trusteed_.] and things look fine now. Are these markdown quirks documented anywhere? I did not see them in the "How do comments work" post. –  Jay Elston Jun 16 '11 at 19:19
    
And I did not find anything about it in the syntax rules at Daring Fireball either. –  Jay Elston Jun 24 '11 at 1:01
add comment

Grace Note is (or rather, was) correct. We've now added square brackets as legal formatting boundaries, so this will work after the next build.

share|improve this answer
add comment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .