What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

This question already has an answer here:

I want to format an SQL table the right way in a Stack Overflow question.

ID Name
1 Tom

I know the example above is not the right way. I even tried an HTML table approach, but it's still wrong. Please help, because I need to include SQL tables later...

share|improve this question

marked as duplicate by РСТȢѸФХѾЦЧШЩЪЫЬѢѤЮѦѪѨѬѠѺѮѰѲѴ, Martijn Pieters May 16 at 12:37

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

5  
I didn't downvote, but at least spelling the name of the site right and not using txtspeak would be much better ;-) –  fretje Jun 23 '11 at 8:31
3  

1 Answer 1

up vote 39 down vote accepted

See

Is there a webapp to create ASCII art tables?

From our very own Senseful!

I just copied and pasted this from SQL Server Management studio:

-1  Community   210
1   Jeff Atwood 5636
2   Geoff Dalgas    148
3   Jarrod Dixon    101
4   Joel Spolsky    959

Into Senseful's web app and got

╔════╦══════════════╦══════╗
║ -1 ║  Community   ║ 210  ║
╠════╬══════════════╬══════╣
║  1 ║ Jeff Atwood  ║ 5636 ║
║  2 ║ Geoff Dalgas ║  148 ║
║  3 ║ Jarrod Dixon ║  101 ║
║  4 ║ Joel Spolsky ║  959 ║
╚════╩══════════════╩══════╝

(I probably should have ticked the "no header" option...)

share|improve this answer
1  
This is still broken for me in FF5. –  Jon Seigel Jul 5 '11 at 2:35
    
@jon still can't repro, see screenshot with Firefox 5 about shown at img220.imageshack.us/img220/765/ff5asciitable.png –  Jeff Atwood Jul 5 '11 at 2:46
    
    
@jon there's something busted in your OS or config somewhere? What OS? I am using Windows 7. I noticed your windows are not themed as if they are on Windows 7.. –  Jeff Atwood Jul 5 '11 at 7:13
    
Win7 x64. I think I have font smoothing or something turned off -- I will play with my settings later today and let you know. –  Jon Seigel Jul 5 '11 at 11:44
    
Enabling ClearType fixed the problem. (I'm turning it back off, though.) –  Jon Seigel Jul 5 '11 at 21:41
    
@JeffAtwood: Glad you found the utility useful! This is exactly the reason I developed it, so thanks for the link! –  Senseful Dec 22 '11 at 2:06
    
@JonSeigel: does using the "MySQL" instead of "Unicode Art" style still make it appear broken for you? –  Senseful Dec 22 '11 at 2:09

Not the answer you're looking for? Browse other questions tagged .