Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I was actually browsing to meta.stackexchange since my question concerns the entire network, but I was redirected here so I guess it's alright to ask this question here.

My problem is the following:

I've first created my stackoverflow account using my OpenID, but I then associated my real e-mail address with this account. Under my account settings I can see my correct e-mail address and my openid account (

Now I wanted to signup to So I clicked StackExchange as my OpenID provider (since I have an account here). I entered the e-mail address which is displayed in my account and my password. However I can't log-in/register this way. It keeps saying that my e-mail address is not recognized.

Now I would prefer to set-up my account as following:

  • un-associate my account (I hardly use it, and it's cumbersome to log in to)
  • Set my StackExchange account as my OpenID provider
  • Log in to StackExchange using my e-mail+password
  • Log in/Register to StackExchange associated sites using the Stack Exchange OpenID.

Is this possible, or am I stuck to using my wordpress account forever now? I would really love to deleted my wordpress account and unfortunately SE is stopping me from doing this now :(.

share|improve this question
up vote 4 down vote accepted

After some more browsing I found this answer:

How do I change my OpenID provider(s)?

In that answer it seems to be possible to use stackexchange itself for login, however when I go the mylogins page now the stackexchange option has disappeared:

Old version with stack exchange option Old version with stack exchange

New Version without stack exchange option New Version that removed SE

However you can still use the manual URL option: to use stackexchange as your openId provider. However why the button was removed I dont know :/.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .