Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

Recently (last two days) I have been getting the following message at the top of every page I visit on Stack Overflow and Meta Stack Overflow.

Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load.

As a result of this message, the following functionality is unavailable.

  • Adding comments.
  • Voting.
  • Controls (image, code buttons, etc.) missing from message posting form and the preview does not appear.
  • Automatic recognition that you are 'not a bot'.
  • Notify daily of new answers option.
  • ...

At first I thought this might be due to a recent Firefox update (Firefox 5.0), but a quick test has Chrome 12.0.742.100 failing with the exact same message. No other changes are known to have happened to this machine since the site began to fail.

The only thing I can guess that might be going wrong is that the (wireless) Internet connection is taking too long to load the pages and hitting some kind of 'time-out'. The problem with that theory is that other sites (e.g. Wikipedia) seem to be loading about as fast as I recall in the past.

How can this be fixed?

I cannot see any closely similar posts, looking through such questions as:

Update based on answer & comment

As mentioned above, I am unable to post comments.

@Jeff Atwood: I downloaded Opera 11.11 (7,648,768 bytes in around 90 seconds (1)) and installed with standard options (except 'Use Opera as my default browser'). I got the same error as Firefox and Chrome.

  1. Which suggests that it is not the connection speed that is the problem.

@Rick Sladkey: I had a look at the thread and am sure no new plug-ins have been installed, and no functionality disabled in Firefox, Chrome and (now) Opera.

Update 2 - Fiddler results

@Rick Sladkey: I suggested throwing Fiddler at it. I'm not sure I can interpret the results, but hopefully others can. It is showing output suspiciously like as described.

The data produced when visiting Stack Overflow using first Firefox and then Opera.

Here is a copy/paste of the textual data.

#    Result    Protocol    Host    URL    Body    Caching    Content-Type    Process    Comments    Custom
1    200    HTTP    /fiddler2/updatecheck.asp?isBeta=False    309    private      text/plain    fiddler:5012
2    200    HTTP    /users/418556/andrew-thompson    13,870    public, max-age=120  Expires: Sat, 25 Jun 2011 07:56:49 GMT    text/html; charset=utf-8    firefox:5264
3    504    HTTP    /ajax/libs/jquery/1.5.2/jquery.min.js    512        text/html; charset=UTF-8    firefox:5264
4    304    HTTP    /avatar/a1ab0af4997654345d7a949877f8037e?s=128&d=identicon&r=PG    0    max-age=300  Expires: Sat, 25 Jun 2011 07:59:51 GMT        firefox:5264
5    204    HTTP    /pixel;r=2062096692;fpan=0;fpa=P0-1054713200-1281019855865;ns=0;;;ce=1;je=1;sr=1920x1080x24;enc=n;ogl=;dst=1;et=1308988487554;tzo=-600;a=p-c1rF4kxgLUzNc    0    private, no-cache, no-store, proxy-revalidate  Expires: Fri, 04 Aug 1978 12:00:00 GMT        firefox:5264
6    200    HTTP    /__utm.gif?utmwv=4.9.5&utms=2&utmn=1079358679&    35    private, no-cache, no-cache=Set-Cookie, proxy-revalidate  Expires: Wed, 19 Apr 2000 11:43:00 GMT    image/gif    firefox:5264
7    200    HTTP    CONNECT    0            firefox:5264
8    200    HTTP    /    1,085    max-age=506567, public, no-transform, must-revalidate  Expires: Fri, 01 Jul 2011 04:37:54 GMT    application/ocsp-response    firefox:5264
9    200    HTTP    CONNECT    0            firefox:5264
10    200    HTTP    CONNECT    0            firefox:5264
11    200    HTTP    /?    410    max-age=7200      text/xml    opera:432
12    504    HTTP    /ajax/libs/jquery/1.5.2/jquery.min.js    512        text/html; charset=UTF-8    opera:432
13    204    HTTP    /posts/96373/ivc/aff0    0    private          opera:432
14    204    HTTP    /pixel;r=214885247;fpan=0;fpa=P0-940893504-1308985983644;ns=0;;ref=;ce=1;je=1;sr=1920x1080x32;enc=n;ogl=;dst=1;et=1308988595022;tzo=-600;a=p-c1rF4kxgLUzNc    0    private, no-cache, no-store, proxy-revalidate  Expires: Fri, 04 Aug 1978 12:00:00 GMT        opera:432
15    200    HTTP    /__utm.gif?utmwv=4.9.5&utms=1&utmn=619136352&    35    private, no-cache, no-cache=Set-Cookie, proxy-revalidate  Expires: Wed, 19 Apr 2000 11:43:00 GMT    image/gif    opera:432

For the screenshots, see Note that Firefox had pages that made further requests within that time, but I scrolled back to the top for the first results as shown above. I was tempted to hot-link to the img at my site (since I cannot use the image button), but decided not to try.

Update 3 - Proxy Server/More on 504

@sth: "Are you using a proxy server?"

Not at the client side, no.

I'm doing all this from a private development machine running Windows 7 with UAC enabled. Since it is a machine I alone control and have access to. I have no reason to install a proxy server (now that I checked what it means at Wikipedia).

Can it be run on the side of my ISP?

The only reason I ask is that my ISP is Australian based, and I heard vague reports that there was a 'secret' black-list of domains that Oz ISPs were supposed to protect the Oz-pop. from. Not that I can imagine how JavaScript at got on the list.

BTW - rather remiss of me not to post the detail of that 504 message. I correct that now. I was hoping it might identify the server that was timing out, but I don't see that information amongst the detail.

Request Count:     1
Bytes Sent:     417    (headers:417; body:0)
Bytes Received: 638    (headers:126; body:512)

ClientConnected:    01:27:12.659
ClientBeginRequest:    01:27:12.758
ClientDoneRequest:    01:27:12.758
Gateway Determination:    0ms
DNS Lookup:         248ms
TCP/IP Connect:        259ms
HTTPS Handshake:    0ms
ServerConnected:    01:27:13.266
FiddlerBeginRequest:    01:27:13.266
ServerGotRequest:    01:27:13.266
ServerBeginResponse:    00:00:00.000
ServerDoneResponse:    01:27:13.455
ClientBeginResponse:    01:27:13.455
ClientDoneResponse:    01:27:13.465

    Overall Elapsed:    00:00:00.7070405

HTTP/504:     1

RESPONSE BYTES (by Content-Type)
text/html:    512
~headers~:    126

The following are VERY rough estimates of download times when hitting servers based in WA, USA.

US West Coast (Modem - 6KB/sec)
Round trip cost: 0.10s
Elapsed Time:     0.10s

Japan / Northern Europe (Modem)
Round trip cost: 0.15s
Elapsed Time:     0.15s

China (Modem)
Round trip cost: 0.45s
Elapsed Time:     0.45s

US West Coast (DSL - 30KB/sec)
Round trip cost: 0.10s
Elapsed Time:     0.10s

Japan / Northern Europe (DSL)
Round trip cost: 0.15s
Elapsed Time:     0.15s

China (DSL)
Round trip cost: 0.45s
Elapsed Time:     0.45s

Learn more about HTTP performance at
share|improve this question
The issue is the line 8 200 HTTP / 1,085 max-age=506567, public, no-transform, must-revalidate Expires: Fri, 01 Jul 2011 04:37:54 GMT application/ocsp-response firefox:5264 The HTTPS protocol cert for jquery.min.js is not able to be validated. Firefox has an option not to treat the cert as invalid if the OCSP server connection fails. Set security.OCSP.require to false. – Geremia Oct 4 '14 at 22:26
up vote 7 down vote accepted

You can try diagnosing the problem at the HTTP level by using a tool like Fiddler.

For example, if you start Fiddler, and then run, say, Internet Explorer, navigate to this very page, and then press Ctrl+F5, you should see output similar to this:

Fiddler Listing

The second line, the one with, is the one I think causing your problems. If you don't see it at all, or if it has some other status than 200, then at least you have something to work with.

share|improve this answer
Thanks Rick. Still not sure what actually caused the problem, but a) it is now fixed, & b) I felt your tip towards Fiddler was the best advice offered on this thread. – Andrew Thompson Jun 26 '11 at 18:32
@Andrew: Sounds like your ISP is using an invisible proxy. Anyway, glad it's resolved. Using StackExchange without scripting is like trying to use a computer without an enter key! – Rick Sladkey Jun 26 '11 at 19:03
While I admired the design of the site that still allowed me to post both questions & answers while the vital script was missing, it was a PITA for basic usability. Re: "ISP running invisible proxy" - I think that is the most likely explanation, and that my message to them caused them to reconsider it (at least in my case, at least for that script). If any more problems are reported from users of an Australian ISP with the numeral "three" in the name, getting directly in contact with the ISP might be the best bet. – Andrew Thompson Jun 27 '11 at 6:13

I had the same message today for the first time, and in my case was blocked by the most recent update of my Avira Antivirus Browser Protection. After adding an exception everything worked again (though I'm sure this would have been temporary anyway and gone in the next update).

share|improve this answer
+1 Thanks. How did you add it? I had the same problem just now. – draks ... Feb 13 '12 at 22:23
@draks: I have a German version of Avira, so the translations are educated guesses. You go to configuration - Internet Security - Search - Exceptions - Exempt URLs from Browser Protection: add all relevant google api URLs here. – Olaf Feb 14 '12 at 17:18
This did the trick for me. Thank you so much! +1 – Sensei76 Feb 14 '12 at 21:16

The problem is most likely the error "504 Gateway Timeout" for when trying to load jQuery. Not sure why that would happen though. Are you using a proxy server?

share|improve this answer
the problem is definitely the 504 gateway timeout on – Jeff Atwood Jun 25 '11 at 18:01
/@Jeff: Problem fixed, details of what was wrong & what is now fixed still not entirely clear. – Andrew Thompson Jun 26 '11 at 18:33

I ran into this exact error message today and also found a solution:

Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load.

Situation: I initially could not work out what the problem was until I noticed I was also receiving a certificate warning for a Google site. Careful reading of the error message indicated that the certificate was valid for a time in the future but the date was for a date in the past. The certificate error message did not appear immediately (Firefox 5 here) but took some minutes to appear.

Problem: The problem turned out to be my date/time settings had somehow slipped out of date and were 21 days (!) behind the actual date. I have no idea how this occurred.

Solution: I reset my date to the correct date and I could now login to Stackoverflow. The Google certificate error messages also disappeared.

I hope my solution also solves the problem for someone else although I doubt this will solve the issue for everybody.

share|improve this answer
"I doubt this will solve the issue for everybody." Maybe not, but it is worth posting if it solves the issue for anybody - your situation already indicates it has. – Andrew Thompson Aug 26 '11 at 17:04

I experience the same same problem since a few days. For me, the problem was that the HTTPS-Everywhere extension loaded the secure version of the Google-APIs instead of the regular version that is requested by Stack Overflow.

Edit: in my case, the problem was resolved by clearing the browser cache.

share|improve this answer
Nice that it helped for you, but I find it weird. Unless the HTTPS version did not exist? – Arjan Jun 30 '13 at 10:25
Indeed, the problem seems to be on Google’s side here: returns not found, whereas the insecure version does exist. – Ruud Jun 30 '13 at 11:54
@RuudvA, Interesting. That URL works for me, and returns a bunch of Javascript. – D.W. Jul 1 '13 at 5:52
This is odd ... when I try the URL in Chrome, IE, or Opera, it works fine. It is only with Firefox that the resource is not found. When I try to send the Firefox request with Opera, the script is retrieved. Actually, the response that Firefox gets is "Not Modified", but Firefox says it is not found. – Ruud Jul 1 '13 at 7:39
Clearing the cache resolved the problem! – Ruud Jul 1 '13 at 7:41

My router (Linksys E2500) allows security settings which filter out "ActiveX" and "Java" - unfortunately, I found that to this router, "Java" means JavaScript. Everything worked again when I disabled that filter. The description for that filter from the documentation is "This filter blocks Java, so you may not be able to access Java content on websites." - I guess Cisco doesn't know the difference 'tween Java and JavaScript. (Side note I turned this filter on because of the zero day exploits in Java until the patches were out - this actually didn't work since the kids were still able to play Minecraft [Java version] even when the filter was turned on)

Check to see if you have enabled a similar filter in your Cisco/Linksys router:

Java filter actually filters JavaScript and not Java ! (Linksys E2500)…

— Mugge (@MikeMugge) March 9, 2013
share|improve this answer
I just learned another really interesting fact about this router: enabling the "Web Filter : ActiveX" setting, will prevent Windows Update from working. When this setting is on and you try to run Windows Update for Windows 7, you get the infamous "8024402f" error. More details:… --AND--… – Mike Mügge Jun 22 '13 at 6:43
That's exactly what my problem was! Thinking I was being smart on my DD-WRT Router I turned on Security > Additional Filters > Filter Java Applets. Then cross domain .js files stopped downloading. I did two weeks ago and then restarted my router yesterday. That was 3 hours I'll never get back. Thanks! – Scott Oct 23 '13 at 13:24

Just within the last hour, the site seems to be back to the way I expect it. No "requires external JavaScript" message, & the ability to comment, up-vote etc.

Some hours ago I sent a support request to my ISP and beyond the form acknowledgement, I have yet to hear back from them.

Perhaps further messages from them will clear this up. Otherwise.. I have no idea what caused the 504 or what fixed it. My best guess is 'continental drift' (which I think indicates just how little idea I have).

share|improve this answer

I got this error using Internet Explorer 10 (IE10). When I went to F12 Developer Tools, I noticed this line occurs in the console:

SEC7114: A download in this page was blocked by Tracking Protection.

There is a little blue< No Symbol in the Address bar. By clicking it and disabling Tracking Protection, the message goes away.

In general I'd say people's problems are due to cross-domain scripting protection from one source or another.

EDIT: I no longer have this problem as of 7/1/2013, but I have a screenshot from when I reported the error to another site if anybody else gets it:

Tracking Protection No Symbol.

share|improve this answer
Happen to have a screen capture of the < No Symbol? – Arjan Jun 30 '13 at 10:42
This occured as late as 6/28/2013, but now I don't get it anymore. I used to get it for a lot of different sites, always having to do with a google api or something on a google CDN. I think IE updated its tracking protection list to exclude these. – Daniel Gimenez Jul 1 '13 at 17:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .