Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 158 Stack Exchange communities.

What is meta?
Here's how it works:
  1. Any Stack Exchange user can ask a question
  2. The community provides support, votes on ideas, and reports bugs
  3. Your voice helps shape the way Stack Exchange operates

I tried to log in to the Data Explorer site, but when I click on the icon for the OpenID provider, I don't see the form field to enter the username.

screenshot

The screenshot shows what I see after I click on the ClickPass icon.

I then entered the URL, which was auto-completed by the browser, but I don't get the right account, as the account shows jon.doe6347 and I was not advised I was creating a new account.

The OpenID I entered is the correct one, as it is visible in the other accounts I have on SE sites. I tried logging in with my other OpenID provider, but all I got is to be logged in as jon.doe6348, even though I used the correct URL.

share|improve this question
up vote 0 down vote accepted

It has been fixed, now. I tried right 5 minutes ago, and I could log in using Safari 5.1 on Mac OS X 10.7.

screenshot

screenshot

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .