What is meta? ×
Meta Stack Exchange is where users like you discuss bugs, features, and support issues that affect the software powering all 131 Stack Exchange communities.

I noticed this when trying to flag posts:

  1. Click on flag;
  2. I changed my mind, and being the lazy one, I tapped the Esc key, the popup disappeared;
  3. I changed my mind again, and now I click on the flag link:

enter image description here

Note this is predictable: If I click it again, the popup would load; press Esc again, then it again breaks down.

Also, if I use Esc to get rid of the picture above, then next time I click it same would happen. But if I use Esc one more time, it returns to normal.

Is this a tricky bug or something?

Thanks!

share|improve this question
2  
Ironic. –  Won't Jul 21 '11 at 14:18
    
@Won't: lololol nice –  Mehrdad Jul 21 '11 at 15:12
1  
Apparently the fact that stackoverflow doesn't gracefully recover from an aborted ajax request is a support request, rather than a bug...? –  Adam Davis Jul 21 '11 at 21:57

3 Answers 3

When you press escape during AJAX request, Stack Overflow's javascript show you error because you aborted AJAX request.

Next time you click it, there is another AJAX call and it should work normally

share|improve this answer
    
So this is more an issue of AJAX? –  Ziyao Wei Jul 21 '11 at 13:55
    
It isn't issue. AJAX is aborted if you press Esc. IN case that AJAX aborts, StackOverflow throws an error. –  genesis Jul 21 '11 at 13:56

As @gensis notes, this is an AJAX request. Try the following:

  1. Click 'flag'.
  2. Wait a few seconds (until the '...' next to the flag link disappears).
  3. Close the dialogue with the 'x' or Esc or the cancel link.
  4. Click 'flag' again.

If you wait long enough, it should work using any of the three methods. Using any of these three methods to close the dialog before it has completely loaded will cause the same notification you see above.

That said, if you dismiss the notification and click flag a third time, it should work again. Hence the please try again. Experimenting here for a few minutes, I believe it is working-by-design because you interrupted the AJAX request. The second click clears the AJAX error. The third click correctly re-opens the dialog.

share|improve this answer
    
Great! Seems that I am too impatient:) –  Ziyao Wei Jul 21 '11 at 13:56
    
As are we all. :O) –  M. Tibbits Jul 21 '11 at 13:58

Another cause of this, that I've just experienced, is a Proxy Auto-Configuration script for redirecting advertising URLs whose pattern matching rules just happen to match the URLs that StackExchange uses for flagging posts. The behaviour is slightly different, in that retrying the request will never succeed.

The re_banner regular expression in John LoVerso's "no ads" PAC script matches StackExchange's post flagging mechanism. It's the */popup/*?_=* form of the StackExchange URL that does it.

Any advertising removal PAC script or HTTP proxy that has a similar regular expression for recognizing popup advertising will block StackExchange's flagging mechanism.

share|improve this answer
    
Thanks for that tip. I had to disable Privoxy 3.0.18 before the flag functionality would work. –  andy holaday Jun 28 '12 at 1:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .