5 replaced http://meta.stackexchange.com/ with https://meta.stackexchange.com/
source | link

Take an example on this questionthis question. Find my comment which read like:

@Johan - Option 2 is already there. 10k+ users can edit deleted posts too.

This is the link of that commentThis is the link of that comment But it is not redirecting us to the comment. The possible reasons I can say is:

  • there are too many comments so some comments are hidden by default including mine.
  • the comment is not upvoted (so it is not showing by default in other words we have to click on add / show X more comments).

When we see all comments then the link redirects us there.


Edit:

After this commentthis comment by @Oded I have found the actual bug:

When all comments are shown the comment's link is like question-link#comment-<CommentID> (which redirects successfully when all comments are shown). But it will not redirect when all comments are not shown. Example link:

http://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699https://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699

To redirect on hidden comments the URL is: question-link#comment<CommentID>_QuestionID. (Which redirects successfully even when all comments are not shown). Example link:

http://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731https://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731

But comment's timestamp gives the first link (without QuestionID). So we need to change that link.

Tested on Chrome (Version 29.0.1547.66 m), Firefox (23.0.1), Windows XP

Take an example on this question. Find my comment which read like:

@Johan - Option 2 is already there. 10k+ users can edit deleted posts too.

This is the link of that comment But it is not redirecting us to the comment. The possible reasons I can say is:

  • there are too many comments so some comments are hidden by default including mine.
  • the comment is not upvoted (so it is not showing by default in other words we have to click on add / show X more comments).

When we see all comments then the link redirects us there.


Edit:

After this comment by @Oded I have found the actual bug:

When all comments are shown the comment's link is like question-link#comment-<CommentID> (which redirects successfully when all comments are shown). But it will not redirect when all comments are not shown. Example link:

http://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699

To redirect on hidden comments the URL is: question-link#comment<CommentID>_QuestionID. (Which redirects successfully even when all comments are not shown). Example link:

http://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731

But comment's timestamp gives the first link (without QuestionID). So we need to change that link.

Tested on Chrome (Version 29.0.1547.66 m), Firefox (23.0.1), Windows XP

Take an example on this question. Find my comment which read like:

@Johan - Option 2 is already there. 10k+ users can edit deleted posts too.

This is the link of that comment But it is not redirecting us to the comment. The possible reasons I can say is:

  • there are too many comments so some comments are hidden by default including mine.
  • the comment is not upvoted (so it is not showing by default in other words we have to click on add / show X more comments).

When we see all comments then the link redirects us there.


Edit:

After this comment by @Oded I have found the actual bug:

When all comments are shown the comment's link is like question-link#comment-<CommentID> (which redirects successfully when all comments are shown). But it will not redirect when all comments are not shown. Example link:

https://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699

To redirect on hidden comments the URL is: question-link#comment<CommentID>_QuestionID. (Which redirects successfully even when all comments are not shown). Example link:

https://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731

But comment's timestamp gives the first link (without QuestionID). So we need to change that link.

Tested on Chrome (Version 29.0.1547.66 m), Firefox (23.0.1), Windows XP

4 Migration of MSO links to MSE links
source | link

Take an example on this questionthis question. Find my comment which read like:

@Johan - Option 2 is already there. 10k+ users can edit deleted posts too.

This is the link of that commentThis is the link of that comment But it is not redirecting us to the comment. The possible reasons I can say is:

  • there are too many comments so some comments are hidden by default including mine.
  • the comment is not upvoted (so it is not showing by default in other words we have to click on add / show X more comments).

When we see all comments then the link redirects us there.


Edit:

After this commentthis comment by @Oded I have found the actual bug:

When all comments are shown the comment's link is like question-link#comment-<CommentID> (which redirects successfully when all comments are shown). But it will not redirect when all comments are not shown. Example link:

http://meta.stackoverflow.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699http://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699

To redirect on hidden comments the URL is: question-link#comment<CommentID>_QuestionID. (Which redirects successfully even when all comments are not shown). Example link:

http://meta.stackoverflow.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731http://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731

But comment's timestamp gives the first link (without QuestionID). So we need to change that link.

Tested on Chrome (Version 29.0.1547.66 m), Firefox (23.0.1), Windows XP

Take an example on this question. Find my comment which read like:

@Johan - Option 2 is already there. 10k+ users can edit deleted posts too.

This is the link of that comment But it is not redirecting us to the comment. The possible reasons I can say is:

  • there are too many comments so some comments are hidden by default including mine.
  • the comment is not upvoted (so it is not showing by default in other words we have to click on add / show X more comments).

When we see all comments then the link redirects us there.


Edit:

After this comment by @Oded I have found the actual bug:

When all comments are shown the comment's link is like question-link#comment-<CommentID> (which redirects successfully when all comments are shown). But it will not redirect when all comments are not shown. Example link:

http://meta.stackoverflow.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699

To redirect on hidden comments the URL is: question-link#comment<CommentID>_QuestionID. (Which redirects successfully even when all comments are not shown). Example link:

http://meta.stackoverflow.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731

But comment's timestamp gives the first link (without QuestionID). So we need to change that link.

Tested on Chrome (Version 29.0.1547.66 m), Firefox (23.0.1), Windows XP

Take an example on this question. Find my comment which read like:

@Johan - Option 2 is already there. 10k+ users can edit deleted posts too.

This is the link of that comment But it is not redirecting us to the comment. The possible reasons I can say is:

  • there are too many comments so some comments are hidden by default including mine.
  • the comment is not upvoted (so it is not showing by default in other words we have to click on add / show X more comments).

When we see all comments then the link redirects us there.


Edit:

After this comment by @Oded I have found the actual bug:

When all comments are shown the comment's link is like question-link#comment-<CommentID> (which redirects successfully when all comments are shown). But it will not redirect when all comments are not shown. Example link:

http://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment-621699

To redirect on hidden comments the URL is: question-link#comment<CommentID>_QuestionID. (Which redirects successfully even when all comments are not shown). Example link:

http://meta.stackexchange.com/questions/196731/can-we-nuke-spam-hate-answers-from-orbit-instead-of-just-marking-them-as-delete#comment621699_196731

But comment's timestamp gives the first link (without QuestionID). So we need to change that link.

Tested on Chrome (Version 29.0.1547.66 m), Firefox (23.0.1), Windows XP

    Post Closed as "off-topic" by hims056, psubsee2003, Martijn Pieters, Arjan, Tobias Kienzler
3 edited tags
| link
2 added 1355 characters in body
source | link
1
source | link