9 replaced http://meta.stackexchange.com/ with https://meta.stackexchange.com/
source | link

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack ExchangeRecent feature changes to Stack Exchange with this revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: http://meta.stackexchange.com/questions/33906/newline-before-closing-pre-might-break-formatting-in-other-parts-of-same-postNewline before closing </pre> might break formatting in other parts of same post.)

Update, this might be related, so for now I'm adding it here:

When manually specifyingmanually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is rendered as:

if(preview != result){ alert("Big difference" + " in final result!"); }

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack Exchange with this revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: http://meta.stackexchange.com/questions/33906/newline-before-closing-pre-might-break-formatting-in-other-parts-of-same-post.)

Update, this might be related, so for now I'm adding it here:

When manually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is rendered as:

if(preview != result){ alert("Big difference" + " in final result!"); }

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack Exchange with this revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: Newline before closing </pre> might break formatting in other parts of same post.)

Update, this might be related, so for now I'm adding it here:

When manually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is rendered as:

if(preview != result){ alert("Big difference" + " in final result!"); }

8 replaced http://meta.stackoverflow.com/ with https://meta.stackoverflow.com/
source | link

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack Exchange with this revisionthis revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: http://meta.stackexchange.com/questions/33906/newline-before-closing-pre-might-break-formatting-in-other-parts-of-same-post.)

Update, this might be related, so for now I'm adding it here:

When manually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is rendered as:

if(preview != result){ alert("Big difference" + " in final result!"); }

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack Exchange with this revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: http://meta.stackexchange.com/questions/33906/newline-before-closing-pre-might-break-formatting-in-other-parts-of-same-post.)

Update, this might be related, so for now I'm adding it here:

When manually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is rendered as:

if(preview != result){ alert("Big difference" + " in final result!"); }

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack Exchange with this revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: http://meta.stackexchange.com/questions/33906/newline-before-closing-pre-might-break-formatting-in-other-parts-of-same-post.)

Update, this might be related, so for now I'm adding it here:

When manually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is rendered as:

if(preview != result){ alert("Big difference" + " in final result!"); }

7 Fixup of bad MSO links to MSE links migration
source | link

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack Exchange with this revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: Newline before closing <http:/pre> might break formatting in other parts of same post/meta.stackexchange.com/questions/33906/newline-before-closing-pre-might-break-formatting-in-other-parts-of-same-post.)

Update, this might be related, so for now I'm adding it here:

When manually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks finelooks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is renderedis rendered as:

  if(preview != result){ alert("Big difference" + " in final result!"); }

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack Exchange with this revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: Newline before closing </pre> might break formatting in other parts of same post.)

Update, this might be related, so for now I'm adding it here:

When manually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is rendered as:

  if(preview != result){ alert("Big difference" + " in final result!"); }

Not a big issue as this won't happen often, if ever again. (But it just scared me a lot when I messed up the Recent feature changes to Stack Exchange with this revision.)

The following does not render as expected:

<!-- Some comment, no blank line following it -->
Text

- List item
- List item

<!-- More comment, followed by blank line -->

More text

This shows fine in the preview, but after saving renders as:

Text - List item - List item
More text

However: adding a blank line below the first comment, or removing the blank line below the second comment, fixes this. (Also completely removing the second comment fixes this.)

The resulting HTML currently is:

<div class="post-text">
Text

- List item
- List item



<p>More text</p>
</div>

rather than:

<div class="post-text"><p>
Text</p>

<ul>
<li>List item</li>
<li>List item</li>
</ul>

<p>
More text</p>
</div>

(This might have the same cause as another edge case, which has been fixed though: http://meta.stackexchange.com/questions/33906/newline-before-closing-pre-might-break-formatting-in-other-parts-of-same-post.)

Update, this might be related, so for now I'm adding it here:

When manually specifying a Prettify language, one needs a bank line between the <!-- language: xx --> line and the code block. However, the preview doesn't care if it's missing. Like the following looks fine in the preview:

<!-- language: javascript -->
    if(preview != result){
      alert("Big difference"
        + " in final result!");
    }

...but is rendered as:

if(preview != result){ alert("Big difference" + " in final result!"); }

6 Migration of MSO links to MSE links
source | link
5 edited tags
| link
4 Fixed title of link by just letting the autogenerated thingy do its magic
source | link
3 Dummy edit for "HTML in title" in http://meta.stackoverflow.com/questions/82013/is-it-possible-to-use-subhtml-sub-in-question-titles/82017#82017
source | link
2 Note on the new manual prettify thingy
source | link
1
source | link