Since yesterday, the mobile version of the stackoverflow site has not been working for me. It displays as though the css is missing, no colors or formatting. It's especially odd since the mobile version of meta displays for me just fine. I'm using the default browser, Android 2.2. I've tried clearing the cache and switching back and forth from the full site. The full site displays just fine. I don't see any question about it, so I hope its not just me.

  • Do you see other websites correctly on your mobile?
    – user162697
    Aug 7 '11 at 19:32
  • Every thing looks good but so mobile.
    – Kratz
    Aug 7 '11 at 19:36
  • updated my answer
    – balpha
    Aug 16 '11 at 7:48

It is fairly certain that this is a bug in the Android browser, which seems to have problems with gzipped content: http://markmail.org/message/fdt7waiki7qrgdax

I can usually fix this temporarily by purging the CDN cache (it worked in this case), but that's obviously not a scalable solution. The thread I linked to above seems to offer a workaround; I'm still waiting for words from our CDN provider regarding a possible implementation of this workaround.

Update: If both my theory and the CDN people's theory about what's causing this are correct, this should now be resolved. All sites (currently except Stack Overflow, I'll switch that later today) now pull their content from a different domain (cdn3.sstatic.net) that should not show this issue. Since this whole thing is totally unreproducible, only time can tell if it's actually fixed.

If tagged this in the assumption that all is well; should the Android browser still show signs of unhappiness, this'll have to be revisted. But I'm an optimist :)

  • When visiting using Android Browser or Opera on my Galaxy S2 I get the following error at the bottom of the page: Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load. I have no such block in place, and the site works fine in Firefox. Aug 16 '11 at 9:26
  • That message is not related to our CDN; it's about not being able to pull jQuery from ajax.googleapis.com.
    – balpha
    Aug 16 '11 at 9:28
  • Is there a fix I can employ (other than using Firefox)? I've tried to soften my JS security settings, but I don't seem to be blocking external linking. Aug 16 '11 at 9:30
  • Impossible to say without knowing what the issue is -- what do you see when you go to ajax.googleapis.com/ajax/libs/jquery/1.5.2/jquery.min.js?
    – balpha
    Aug 16 '11 at 9:54
  • I get the JavaScript file as text. Returning to SO mobile site afterwards still gives the error. Aug 16 '11 at 10:01
  • First, try clearing the browser cache. If that doesn't help, type about:debug in the Android browser's location bar (and possibly reload the page). You should then get the JavaScript error console.
    – balpha
    Aug 16 '11 at 10:11
  • Uncaught SyntaxError: Unexpected token : on line 1 of the jquery script, followed by a couple of undefined $ from SO (obviously). Aug 16 '11 at 10:16
  • Hmm. No idea, honestly. I also can't reproduce; works just fine in my Android browser (HTC Desire). And if you actually see the JS file just fine, this really seems like a caching error in that browser. Aside from clearing cache, killing the browser, rebooting the phone, I'm out of ideas; sorry.
    – balpha
    Aug 16 '11 at 10:29
  • I've tried all of the above, and raised the issue on the android site as well. The strangest thing is that it affects Opera too. Looks like a factory reset is going to be required :( Aug 16 '11 at 10:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .