Possible Duplicate:
disabled Approve / Reject / Improve buttons

Sometimes the approve/reject buttons are disabled in Suggested Edits. This may or may not have a reason (while the reasons mentioned in this thread don't cut it — only some posts are disabled and after I refresh, other posts are disabled), but it becomes more surprising when I click the post-link. If I click through on the "edit pending" or "edit (0)" link in the post, the buttons are enabled again.

Either this is a workaround to something I'm actually forbidden to do, in which case it may be a bug, or the disabled buttons weren't correct to begin with, especially when considering that for one and the same posts, they were enabled first, after refresh disabled and after refresh again enabled — etc.

Screenshot disabled buttons inside the suggested edits

Disabled buttons inside suggested edits

Screenshot enabled buttons inside actual post

Enabled buttons inside the actual post

  • Like it says in the comments to the answer for the other question, it happens even when the conditions for disabling are not fulfilled. Reloading the page turns the buttons on and you can approve or reject the post where they were disabled.
    – Bo Persson
    Aug 10, 2011 at 14:31
  • @Bo Persson: Hmm, then I just don't understand it, I'm afraid. I didn't get that from the response in my other thread and I still don't. Do you mean it is random? Like a roulette? Is that by design / on purpose and do I just fail to see the deeper meaning?
    – Abel
    Aug 10, 2011 at 15:12
  • I don't understand it either. :-) Always thought it was a bug, because sometimes when two edits fit on the screen (using review tools) one of them can have enabled buttons and the other disabled. After a refresh they are all enabled and can be used. That rules out the possible conditions listed in the other answer, like not enough rep, out of votes, voting 5 times on the same guy, or voting for my own edits. None of that happens.
    – Bo Persson
    Aug 10, 2011 at 15:27
  • 1
    "After a refresh they are all enabled and can be used." >> not always, which makes it even more odd: sometimes a refresh helps, sometimes a refresh causes previously clickable buttons to become unclickable and the reverse. Sometimes all posts are clickable, then after a refresh, some posts aren't anymore. Roulette, weird. Probably a bug.
    – Abel
    Aug 11, 2011 at 8:09
  • I am having some trouble with a repro here ... need more details, is this browser specific? Are you able to reproduce this some how? I can not find the code that disables these buttons, something that is leaving me real confused
    – waffles
    Aug 22, 2011 at 2:10
  • I use Safari on an iPad. Abel probably doesn't, considering his screenshots. Can't really consistently repro it either as the problem goes away when I reload the page.
    – Bo Persson
    Aug 22, 2011 at 16:36
  • @waffles: I use FF for most of my tasks, but had the same problem on Opera and IE. The circumstances seem to be only after I spent quite some time in the area and go back and forth from that page. Sometimes refresh helps, sometimes it makes it worse.
    – Abel
    Aug 23, 2011 at 21:24
  • I've been experiencing this for at least a couple of months, Firefox (4, 7, 9 and 10) on Ubuntu (10.10 and now 11.04). Never tried it a different browser. I find that if it's not got some disabled the first time I look at it in a day, if I refresh a couple of times it will be, invariably. (This is on Stack Overflow.) @Abel's "roulette" comment is also my experience. Nov 23, 2011 at 11:37

1 Answer 1


I've finally come up with a workaround that seems to work. I don't know why.

Open the page again in a new tab.

  • Hey! I like that better than my workaround (opening the suggested edit page for each individual edit suggestion; the buttons work there) because this actually enables them all again. Woot. I wish the Suggested Edits page just worked, but this has been broken for at least ten months, so I don't hold out much hope of it being fixed -- apparently none of the staff can reproduce it.
    – sarnold
    Feb 16, 2012 at 0:04
  • I've observed this behavior fairly often in Firefox 3, rarely in Firefox 13, and never with Chrome. So using Chrome instead of Firefox may help. I'm not sure whether the browser is the relevant factor, however, because the machines where I predominantly use Firefox are behind a web proxy whereas the machines where I predominantly use Chrome aren't — so maybe the solution is to avoid broken proxies. Jul 11, 2012 at 19:34

Not the answer you're looking for? Browse other questions tagged .