6

I originally thought this was a mobile-theme related issue, but it is not. The css of the page does not load.

I guess I could clear my browser's cache. Is there any other option?

screenshot

Edit: I do not have the "full site" option at the very bottom :(

screenshot

Edit2: this is not an issue with the mobile theme. Here's my data according to the requests from this post

Samble CDN file: http://cdn.sstatic.net/js/stub.js?v=d5ace739b006
My IP: 186.48.230.46
Tracing route to sstatic.stackexchange.netdna-cdn.com [69.174.57.102] over a maximum of 30 hops:

1 21 ms 15 ms 25 ms pucor1bras1.antel.net.uy [200.40.21.7]
2 16 ms 16 ms 18 ms ibb2cor1-7-2-93.antel.net.uy [200.40.21.81]
3 20 ms 16 ms 16 ms ibb2agu1-1-3.antel.net.uy [200.40.16.73]
4 29 ms 56 ms 21 ms ibr3agu1-p1.antel.net.uy [200.40.18.38]
5 167 ms 159 ms 159 ms So5-2-0-0-grtbueba2.red.telefonica-wholesale.net.7.16.84.in-addr.arpa [84.16.7.57]
6 156 ms 159 ms 163 ms Xe5-1-3-0-grtmiabr7.red.telefonica-wholesale.net.125.142.94.in-addr.arpa [94.142.125.122]
7 200 ms 209 ms 186 ms Xe-0-0-2-0-grtwaseq3.red.telefonica-wholesale.net [94.142.124.109]
8 198 ms * 196 ms 213.140.55.90
9 199 ms 197 ms 204 ms po2-20G.ar4.DCA3.gblx.net [67.16.133.82]
10 222 ms 195 ms 194 ms PACKETEXCHANGE-LTD.TenGigabitEthernet2-4.ar4.DCA3.gblx.net [64.211.83.106]
11 205 ms 197 ms 197 ms te4-7.cr1.was2.us.packetexchange.net [69.174.120.125]
12 180 ms 206 ms 188 ms 69.174.31.2
13 194 ms 192 ms 221 ms 69.174.57.102

Trace complete.

Tracert to the origin: Tracing route to sstatic.net [64.34.119.12] over a maximum of 30 hops:

1 29 ms 33 ms 38 ms pucor1bras1.antel.net.uy [200.40.21.7]
2 38 ms 19 ms 16 ms ibb2cor2-7-2-93.antel.net.uy [200.40.21.209]
3 66 ms 93 ms 73 ms ibb2uni2-1-3.antel.net.uy [200.40.16.98]
4 46 ms 24 ms 20 ms ibr3uni1-p2.antel.net.uy [200.40.22.166]
5 214 ms 224 ms 198 ms so-3-1-0.mia11.ip4.tinet.net [77.67.78.189]
6 221 ms 253 ms 224 ms xe-0-2-0.nyc20.ip4.tinet.net [89.149.183.2]
7 301 ms 291 ms 304 ms peer1-gw.ip4.tinet.net [77.67.70.194]
8 230 ms 225 ms 223 ms 10ge.xe-0-0-0.nyc-telx-dis-2.peer1.net [216.187.115.182]
9 263 ms 204 ms 199 ms oc48-po3-0.nyc-75bre-dis-1.peer1.net [216.187.115.134]
10 209 ms 208 ms 207 ms gwny01.stackoverflow.com [64.34.41.58]
11 202 ms 217 ms 221 ms stackoverflow.com [64.34.119.12]

Trace complete.
Datacenter: Miami

  • Why is clearing your cache not the only option? – random Aug 13 '11 at 13:41
  • 4
    This looks like the css isn't loading rather than being stuck in the mobile theme. – ChrisF Aug 13 '11 at 14:22
  • at the very bottom the mobile link appears as selected, not a link – sebagomez Aug 13 '11 at 15:43
  • I'm on a mobile device and CSS is missing in mobile view e.g. for SO. – oleschri Aug 13 '11 at 19:36
  • They have fixed a few issues at the CDN provider; can you confirm this isn't happening anymore, or are you still having problems? – balpha Aug 22 '11 at 13:28
  • Aha! I knew something was going on... I sent an email and they answered saying I shouldn't be sending email to them... Nobody told me they did have a problem... thanks – sebagomez Aug 22 '11 at 19:48
11

This is not the mobile theme, the static resources aren't getting loaded. Try a hard refresh, if that doesn't work, try clearing your cache. You might be having problems reaching the cdn,. There are some troubleshooting steps posted here that you could try if that is the case.

  • I guess you're right... I did pay attention to that or even try to debug the css load... there's actually no css at all... I did try to clear the cache but still facing the same problem... I'm in Uruguay (south america btw) – sebagomez Aug 13 '11 at 18:58
  • Did you do anything with cdn that I suggested? – Rebecca Chernoff Aug 13 '11 at 19:01
  • I pasted my data in the body of the question... what should I do now? – sebagomez Aug 14 '11 at 16:32
2

I found my problem: I had disabled HTTP 1.1 on IE9 when working on something else and I forgot to turn it back on. Once it was back on the problem went away.

1

In my case, I tried all the regular things: Clearing browser data (cache and history), testing other networks and even a hotspot, hard refresh (Shift + F5), rebooting, disabling my antivirus; none of these had any effect. My problem wasn’t just with SO, but with other sites as well, and from various countries. I was surprised to realise the solution: What did make the difference, was disabling Adblock. I tried reloading the page after reenabling AdBlock, and the CSS was again not loading.

Solution № 3: Disable Adblock. This is how you do it:

  • At the top of you browser, there is an icon displaying a stop sign with a stopping hand embossed on top of it. If your Adblock is running, the stop sign is red.
  • Click the icon, then choose either ‘Pause on this site’ or ‘Pause on all sites’; the sign will turn green with a thumbs up symbol embossed.
  • Refresh the page regularly (F5), or if that doesn’t work, do a hard refresh (Shift+F5).

As commented by @Markus Pscheidt, if this method works, one can open the same menu as described above, and select ‘Don’t run on this page’, which disables AdBlock for the entire site.

  • Ad-Block was the culprit – Markus Pscheidt Aug 23 '18 at 15:10
  • Question I have now, which I haven’t had the time to go into, is how I filter sites to be whitelisted. Yes, it is possible to select ‘Dont’t run on this page’, but I am assuming that would only select that specific URL, and sites like SO have probably in the tens of thousands of individual pages, so that is not an acceptable solution. I wish there was a ‘Don’t run on this site’ option as well. – Canned Man Aug 24 '18 at 8:00
  • Deactivating Ad-Block for the site does indeed work for all pages of the site. – Markus Pscheidt Aug 24 '18 at 8:29
  • Whoulda thunk‽ Maybe someone needs to instruct them on their terminology. I’ll update my answer as per your reply. – Canned Man Aug 24 '18 at 10:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .