I recently crossed over 3k rep on SO so "close" (or "reopen") links have now started appearing for me. However when I click on a close link I get a brief "twirly" progress animation in place, followed by... nothing.

I'm using Firefox 3.6.22 on Windows XP. I have Javascript enabled. The only extensions I have are:


  • Chatzilla
  • keyconfig
  • LeechBlock


  • Greasemonkey (with a couple of Livejournal-only user scrips)
  • Java Console 6.0.27
  • Java Quick Starter 1.0
  • Microsoft .NET Framework Assistant 1.2.1
  • Tab Mix PLus
  • TortoiseSVN Menu 0.2.5
  • VMWare Remote Conosle Plug-in

I don't know enough about web-related stuff to have any idea as to whether any of these might affect the behaviour of the close link.

I have tried it in Chrome and it works as expected there, popping up a small window with radio buttons for the various close options.

  • Have you cleared your cache?
    – random
    Sep 16 '11 at 12:21
  • @random: I hadn't, but now I have, and it didn't make any difference. In frustration I then clicked on "close" on a question several times in quick succession, on about the fourth or fifth click I got an orange box saying "Unable to load pop up. Click on this box to dismiss".
    – Vicky
    Sep 16 '11 at 12:23
  • I should also add that I have a similar issue in Firefox with our build server at work, which uses pop ups of some sort for dialogs. Again it works fine in Chrome.
    – Vicky
    Sep 16 '11 at 12:25
  • have you tried starting Firefox in safe mode? Does it work in Chrome or another browser? Sep 16 '11 at 12:30
  • @Jeff Atwood: It does work in Chrome as I mentioned. It turns out it also works with Firefox in Safe Mode. Is there any easy way to find out which of the Safe Mode settings is making the difference?
    – Vicky
    Sep 16 '11 at 13:17
  • It's probably Tabs Mix Plus. Disable that and see if it works
    – random
    Sep 16 '11 at 13:19
  • @random - Nope. In fact I just tried Firefox in normal (not safe) mode and went through and disabled every single extension and plug in, still no joy. So it must be one of the "user settings", although I have no idea how to find out which!
    – Vicky
    Sep 16 '11 at 13:22
  • Have you tried a supported browser?
    – user154510
    Sep 16 '11 at 15:23
  • @Matthew Read: Gosh, thanks for the link. I had actually not realised that Firefox had come through so many iterations in the last 18 months or so. I guess I shouldn't complain - even a Chrome version from less than 6 months ago is noted in that list as "probably unsupported (old version)".
    – Vicky
    Sep 16 '11 at 15:49
  • @Vicky Mozilla seems to have felt the need to keep up with Chrome's rapid versioning, but they keep breaking backwards compatibility :(
    – user154510
    Sep 16 '11 at 17:48

I have now solved this issue.

I had a "userContent.css" file in %APP_DATA%\Mozilla\Firefox\Profiles\y06a2da6.default\chrome\userContent.css which contained some pop up blocking code for iframes incorporating various strings such as "/ad", "/banner", "/splash" etc.

It looks as though the "close" dialog on StackOverflow was somehow getting caught in this. I've removed the userContent.css file and it now all works fine.


We can't repro this; if you've cleared cache, we strongly suspect it's some specific oddity in your browser configuration.

  • thanks for trying it! I've just upgraded to Firefox 6.0.2 (the current default download version) and I'm still seeing the same issue - of course it's brought all my settings with it during the upgrade. I've been through everything that's visible under Tools -> Options and nothing looks particularly suspicious. I don't have pop ups blocked, for instance.
    – Vicky
    Sep 19 '11 at 10:56
  • did you try in Firefox Safe Mode? support.mozilla.com/en-US/kb/Safe%20Mode Sep 19 '11 at 10:58
  • I did, and it's fine in Safe Mode, but manually disabling all add-ons (not in safe mode) doesn't help.
    – Vicky
    Sep 19 '11 at 11:03
  • I've now opened this as a support question on the Firefox Help site: support.mozilla.com/en-US/questions/877256
    – Vicky
    Sep 20 '11 at 9:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .