Possible Duplicate:
Avatar not visible in thumbs?

I guess we'll see if it happens with this post, but if I go here, my card doesn't load the small image from gravitar in Safari. When the expanded card opens, it shows the question mark for a second and then loads the larger image.

But this seems to work in Firefox?

Is it just me? I tried clearing my cache. Does Safari have some sort of super-cache!?

EDIT: It does in fact happen on this post, and I forgot to mention that when I right click and go 'View Image in New Tab' it does successfully load the image in a new tab.

  • @Arjan Yeah it is. – Dave Sep 28 '11 at 19:18
  • No need to delete, dupes aid in search :) – Matthew Read Sep 28 '11 at 19:21
  • @Arjan yeah I can delete it, but perhaps you should add a couple more tags to that other question so it's a bit more searchable. – Dave Sep 28 '11 at 19:22
  • Ok I won't delete it! : ) I did both Command-R and explicit "Empty Cache..." I have noticed a similar infinite cache problem in Safari on sites I've been developing, but not sure if I ever tried just quitting it. – Dave Sep 28 '11 at 19:23
  • For future reference, Safari's Web Inspector shows this for a normal page refresh, if (it thinks) it has cached a previous good version. – Arjan Sep 28 '11 at 19:26
  • And as for Super Cache: ever tried to clear its HTML Local Storage? (Not related to the above issue.) As far as I know, one needs to delete files on the file system to achieve that... – Arjan Sep 28 '11 at 19:27
  • That's horrifying. – Dave Sep 28 '11 at 19:28
  • Note sure what tags to add to that other question; if one knows it's a caching issue, then it is already kind of off-topic here...? – Arjan Sep 28 '11 at 19:49
  • @Arjan Yeah it is, but you're going to keep getting it, since it seems to keep happening with these gravitars. Maybe 'cache' or 'browser' or something. Or a better title? I dunno. – Dave Sep 28 '11 at 19:59
  • Ah geez it's happened again, I've only been working for like half an hour. This might be something that needs to be taken up with gravitar? – Dave Sep 28 '11 at 20:26
  • If you're on a Mac, and if it happens again in Safari, then please run the 2nd sqlite3 command and the file command to figure out what happened? Thanks! – Arjan Sep 28 '11 at 22:45
  • @Arjan, done and done. It is the correct png. I got the same result for file .. and I can open it in preview fine. – Dave Sep 28 '11 at 22:48
  • ...but: you already cleared your cache after posting your comment 2 hours ago? Or is it still NOT showing correctly in Safari? – Arjan Sep 28 '11 at 22:49
  • I had cleared my cache, which did nothing, and then quit Safari, which worked... and then randomly stopped working. I'll try quitting again but I bet it works. – Dave Sep 28 '11 at 22:50
  • I've removed the grep from the 1st command; given the Last-Modified, did you indeed change your avatar on Mon, 26 Sep 2011 03:26:56 GMT? And what value for <Date> do you get? – Arjan Sep 28 '11 at 23:04

According to Avatar not visible in thumbs I quit my browser and now everything works.

Not sure why clearing the cache didn't work, or why this did...

EDIT: or why I didn't think of trying it originally (have you tried turning it off and on again?)


A bit too long for a comment, but to see what has been cached by Safari on a Mac, paste the following into Terminal:

sqlite3 ~/Library/Caches/com.apple.Safari/Cache.db "
    select r.time_stamp, r.request_key, d.response_object
    from cfurl_cache_response r, cfurl_cache_blob_data d 
    where r.entry_ID = d.entry_ID
    and r.request_key like

This will show you some hard-to-read details including the URLs for your small and large avatar, the time they were fetched and the content types of the responses. Like, partial output:

<string>Wed, 28 Sep 2011 19:22:00 GMT</string>
<string>Wed, 28 Sep 2011 19:27:00 GMT</string>
<string>Mon, 26 Sep 2011 03:26:56 GMT</string>

Or to get your own small thumb from the cache into a file:

sqlite3 ~/Library/Caches/com.apple.Safari/Cache.db "
    select hex(d.receiver_data)
    from cfurl_cache_response r, cfurl_cache_blob_data d 
    where r.entry_ID = d.entry_ID
    and r.request_key = 'http://www.gravatar.com/avatar/' ||
  " | xxd -r -p > safari-cache.temp

Next, to see the file type:

file safari-cache.temp

The latter shows me:

safari-cache.temp: PNG image, 32 x 32, 8-bit/color RGBA, non-interlaced

Not the answer you're looking for? Browse other questions tagged .